Scriptrunner error in the Jira logs needs to get addressed

Hi There,

Here is the Scriptrunner error to which we were asked to reach you by the JIRA Support team.


Scriptrunner -error

2.   
3.  2016-04-16 22:57:47,238 JIRA-Bootstrap ERROR      [c.a.p.osgi.factory.OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.onresolve.jira.groovy.groovyrunner' : Unresolved constraint in bundle com.onresolve.jira.groovy.groovyrunner [179]: Unable to resolve 179.0: missing requirement [179.0] osgi.wiring.package; (osgi.wiring.package=com.atlassian.jira.action.admin).  This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN
4.  2016-04-16 22:57:47,242 JIRA-Bootstrap WARN      [c.a.plugin.impl.AbstractPlugin] Unable to enable plugin 'com.onresolve.jira.groovy.groovyrunner'
5.  2016-04-16 22:57:47,242 JIRA-Bootstrap WARN      [c.a.plugin.impl.AbstractPlugin] Because of this exception
6.  com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.onresolve.jira.groovy.groovyrunner
7.    at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:419)
8.  ...
9.  Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.onresolve.jira.groovy.groovyrunner [179]: Unable to resolve 179.0: missing requirement [179.0] osgi.wiring.package; (osgi.wiring.package=com.atlassian.jira.action.admin)
10.  at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974)


Thanks,
John

2 answers

This widget could not be displayed.

Is this preventing ScriptRunner from starting?

Which version of JIRA and ScriptRunner are you using?

This widget could not be displayed.

Yes I guess. We noticed this error on the error logs.
Jira Version - v7.1.2
Installed version: 2.1.16

2.1.16 is not compatible with 7.1.2. You need to address that. You can see the compatibility at https://marketplace.atlassian.com/plugins/com.onresolve.jira.groovy.groovyrunner/versions.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

295 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you