Scriptrunner Behaviour not working consistently

I have utilised the Behaviour Functionality in Scriptrunner (v3.1.3) to setup default values for the Description field for one specific project in our JIRA Instance.

I first set this up in our JIRA Test environment (v6.4.11) and it works successfully as I would expect.

When replicating this in our JIRA Prod environment (also v6.4.11), the description field simply doesn't populate with the default values at all. Our two instances are very similar and the project being mapped is identical. I have also copied and pasted over the serverside script so it is identical too.

I have other Behaviours setup (not using the initialiser function) that are working just fine.

The screenshot attached shows the script used across both our instances.

Can you please help us to investigate what might be causing this issue? Is it coming down to some other conflict in our Prod JIRA and if so, what kind of other things could be conflicting with Behaviours.

I have raised a ticket here also: https://productsupport.adaptavist.com/servicedesk/customer/portal/2/SRJSUP-731

 

Screen Shot 2016-08-09 at 10.01.47 am.png

4 answers

1 accepted

This widget could not be displayed.

Hi Anika,

You use an old version and there are bugs that have not (and are not in high priority) to be fixed for versions prior to 4.*. Therefore an alternative way to retrieve your log files is documented [here|https://confluence.atlassian.com/jira/where-are-the-application-server-logs-16121981.html] Make sure first that you have enabled logging for SR

 

This widget could not be displayed.

Hi Anika,

Do you get any errors in your logs ?

This widget could not be displayed.

Hi Thanos,

I'm actually having problems generating the logs - please see the screenshot attached. I followed these instructions: https://www.adaptavist.com/doco/display/SFJ/How+do+I+get+my+atlassian-jira.log+file 

Screen Shot 2016-08-15 at 2.30.39 pm.png

Look forward to hearing back,

Thanks

Anika

This widget could not be displayed.

Hi Thanos

I have been able to generate the atlassian-jira.log file now - but not the application server log file. What is the best way for me to send this to you? 

Thanks,

Anika

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 9 hours ago in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

27 views 1 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you