ScriptRunner - Escalation Service doesn't work with interval

Hey there,

Got some escalation services on an instance ~about 10.
They are all like this below to automatic transition issues in another project which are linked with this in a special sort of link.

If I "Run now" this services they work fine - but they total ignore the interval and do nothing themself.

any ideas ?

JIRA 6.3.7. and Script Runner 3.0.6 

Description:Resolved -> Closed
Interval:5
JQL:project = "X" and issueFunction in linkedIssuesOf("status = Closed", "is Work-Ticket to") and status changed from Resolved
Action:701 Close Issue
Run as:admin
Additional Code: 
Operations:

Edit Delete

2 answers

1 vote
Mizan Community Champion Nov 26, 2014

I had faced the same earlier , I restarted the plugin service which you can find in JIRA services .

This solved my issue and the configured services worked as expected.

... ok - there is totally no service in there except the standard :(

Mizan Community Champion Nov 26, 2014

Goto : System >> Services >> search for com.onresolve.jira.groovy.canned.admin.EscalationService:job Then click on edit then update .

Name / Class Properties Delay (mins) Mail Queue Service com.atlassian.jira.service.services.mail.MailQueueService 1 Sicherungsdienst com.atlassian.jira.service.services.export.ExportService USE_DEFAULT_DIRECTORY: true 720 Von JIRA Service Desk verwendeter Mailhandler. Darf nicht geändert oder gelöscht werden. 10.100 com.atlassian.servicedesk.squalor.email.ServiceDeskMailFetcherService handler.params: SD_MAIL_SERVER_ID=10100 popserver: Mailserver für x@x.net. Von JIRA Service Desk erstellt. 1 Audit log cleaning service com.atlassian.jira.service.services.auditing.AuditLogCleaningService 1440

Nothing to search here - and if I try to set a new it doesn't work as well with the class you mentioned :(

Mizan Community Champion Nov 26, 2014

I believe this is the reason the escalation service is not working . Check if all modules of the Script runner plugin are enabled. OR may be @Jamie Echlin [Adaptavist] the author of Script runner can help you here.

Well, that is definitely the reason for that problem, as the service triggers the defines escalations. We have faced the same problem since several versions. What i know is: - You need the service which triggers the execution. - This service should run every minute What I do not know is: Whats the classname of the service (adding the class names above doesnt work) Maybe @Jamie Echlin [Adaptavist] Knows the right answer ;)

Hi, I am facing the same problem here. Has anyone sorted out this issue by now?

@Virgil Carcu if this is still an issue can you add the versions please.

@Jamie Echlin [Adaptavist] it works now, thank you!

0 vote

Just cleaning things up. Problems are scheduling are fixed by upgrading to, I think it was, 3.1.3. All the scheduling code was rewritten and should be much more reliable.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

78 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you