Script runner send custom email problem

Hello Everyone,

I seem to be having an issue trying to get my post function custom email to work. Everything appears to work fine if I preview the email through the admin settings but once I put everything in place in my workflow I recieve errors saying the property is not found.

could it be the way I wrote my code ?

<%

if(cfValues['Comment'])
  {
    out << "Test : ${cfValues['Comment']}"
  }
  else
  {
  out << "Test."
  }

%>

1 answer

1 accepted

This widget could not be displayed.
Henning Tietgens Community Champion Oct 23, 2013

Try the same not using GStrings ${} feature. So instead

"Test : ${cfValues['Comment']}"

write

"Test " + cfValues['Comment']

Henning Tietgens Community Champion Oct 23, 2013

Is "Comment" a custom field? If not, you should write transientVars.comment instead.

Thats Great! Thank you very much that was exactly what I was looking for.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

179 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you