Script Runner Validator Bug?

I added this to a Transition.


Script workflow function : Simple scripted validator : Checks script:

cfValues['CF1'] != cfValues['CF2']

 

This Transition was from status A to status B. I seted CF1 = 001 and CF2 = 001.

And very strange is that this function didn't work. But when I throuht another transition form B to C than C to A.

Then this validator works!

The CFs and other propertites are almost the same.

Can someone tells me what is the matter? 

Thanks very much.

1 answer

Is there any one can give me any advices?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

383 views 4 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you