Script Runner Validator Bug?

I added this to a Transition.


Script workflow function : Simple scripted validator : Checks script:

cfValues['CF1'] != cfValues['CF2']

 

This Transition was from status A to status B. I seted CF1 = 001 and CF2 = 001.

And very strange is that this function didn't work. But when I throuht another transition form B to C than C to A.

Then this validator works!

The CFs and other propertites are almost the same.

Can someone tells me what is the matter? 

Thanks very much.

1 answer

This widget could not be displayed.

Is there any one can give me any advices?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

224 views 3 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you