Screens Fail to Appear with Base URL Change and Filters Edited

I've changed the base url of a Jira instance and everything works fine, except when having searched for some issues and then selecting an issue then none of the screens for that issue will open.

If I open the issue in a new tab so that the url is simply 

http://jira/browse/INTRA-140

instead of

http://jira/browse/INTRA-140?jql=project%20%3D%20INTRA%20AND%20resolution%20%3D%20Unresolved%20AND%20component%20%3D%20Shipping

then the screens all function correctly.

Any ideas?

There's a 400 bad request returned from IIS which is doing the URL rewrite.

1 answer

Did you update the server.xml file to specify the proxy url?

Yes - the proxyName and proxyPort settings are both set as below:

proxyName="jira"
proxyPort="80"

Did you set a scheme attribute?

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,323 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot