Screens Fail to Appear with Base URL Change and Filters Edited

I've changed the base url of a Jira instance and everything works fine, except when having searched for some issues and then selecting an issue then none of the screens for that issue will open.

If I open the issue in a new tab so that the url is simply 

http://jira/browse/INTRA-140

instead of

http://jira/browse/INTRA-140?jql=project%20%3D%20INTRA%20AND%20resolution%20%3D%20Unresolved%20AND%20component%20%3D%20Shipping

then the screens all function correctly.

Any ideas?

There's a 400 bad request returned from IIS which is doing the URL rewrite.

1 answer

Did you update the server.xml file to specify the proxy url?

Yes - the proxyName and proxyPort settings are both set as below:

proxyName="jira"
proxyPort="80"

Did you set a scheme attribute?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

688 views 6 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you