Run Jira as a service : JAVA_HOME is not defined

Hi, I have intalled Jira 6.1, not as a service, but now I would like to run it as a service:

I followed that procedure but I I get an error message telling me that JAVA_HOME is not defined, even though I defined it:

7 answers

1 accepted

This widget could not be displayed.

Hmm, Windows 2003, storage server - odd choice of platform.

Main problem here is that you need to be running AT LEAST JDK 1.6 to run Jira 6.0.

Tarun Sapra Community Champion Oct 31, 2013

"odd choice of platform." - is an Understatement ;)

It's a test server to prepare an upgrade of Jira. But you're right, I should also upgrade the OS, not only Jira. Thanks.

This widget could not be displayed.

As you can see on the document that you have provided, it stated Ensure the JAVA_HOME variable is set to the root of your Java platform's installation directory.

You can follow this document to set JAVA_HOME variable on your Windows.

Best Regards

Steven

This widget could not be displayed.

It seem that your JAVA_HOME should be pointed to C:\j2sdk1.4.2_10\<jre drectory>

Reference document: https://confluence.atlassian.com/display/DOC/Setting+the+JAVA_HOME+Variable+in+Windows

This widget could not be displayed.

Hi Steven, I tried to point JAVA_HOME to the jre directory, but it didn't change anything. Then I set JRE_HOME, and here's what I got :

And there are no entries in the jira log file...

This widget could not be displayed.
Tarun Sapra Community Champion Oct 31, 2013

I don't think that Jira 6.x is really compatible with jdk4.x

I have installed jdk1.7 and it didn't change:

Do you know why it ignores JAVA_HOME?

This widget could not be displayed.

Try using java jdk 1.7 version.

And which OS(provide me the bit also) you are using to run this service?

And see this link may helps you.

This widget could not be displayed.

May be the problem is due to failure to locate "MSVCR71.DLL", which can be found in %JAVA_HOME%/bin. There are two options to resolve this problem:

  • Add %JAVA_HOME/bin to PATH, then restart the JIRA server.
  • Copy MSVCR71.DLL to system path, C:\WINDOWS\SYSTEM32 or C:\WINNT\SYSTEM32

And You cannot run JIRA as a service on a 64-bit operating system

Thanks, but these two options are for jdk1.6 and I tried with jdk1.7...

My OS is Windows Server 2003 32 bits.

Maybe I should try to re-install Jira and simply tick the box "install jira as a service".

Tarun Sapra Community Champion Oct 31, 2013

Hi Pierre,

Why aren't you upgrading your OS, your gonna run into lot of compatibility issues, as it's really really outdated.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

536 views 23 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you