Resolve issue on creation

I tried making a custom workflow with just one state - Registered. After creating the issue, it was supposed to resolve automatically, so I added the Post Function (in the Create(1) transition):

The Resolution of the issue will be set to 1.
Edit | Move Down | Delete

However, after creation of this issue, this field remains unresolved.

Is it a bug or does JIRA just not allow to create issues that are already fixed?

P.S. I already fixed the problem by adding this code to my plugin:

Resolution resolution = resolutionManager.getResolutionByName("Fixed");
oIssue.setResolutionObject(resolution);
issueManager.updateIssue(this.GetCurrentUser(), oIssue, EventDispatchOption.DO_NOT_DISPATCH, false);

However, I'd still like to know why Post Function did not work.

1 answer

0 votes

Probably it is the order of the post function. Did you try putting it at the end?

Yes, I tried moving it to the bottom, didn't change anything

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,531 views 15 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you