Recieve an error when attempting to connect to the JIRA Web Services from the QA Complete Connector

When attempting to call the JIRA Web Services from the QA Complete Connector I am receiving the error

Failed to initialise jira web service client due to OH-JIRA-0023: Remote error while calling web service method getServerInfo.

Please advise as to the reason for this error code and possible resolutions.

Many thanks

1 answer

1 accepted

1 vote
Answer accepted

It can't connect to Jira.

Make sure the external api is enabled in Jira (admin -> general configuration) and then read the log files for both Jira and QA. One thing to look at - a lot of stuff fails to talk to Jira over SSL, so are you using https? Jira is fine over SSL, it's usually the other application that struggles, but it's worth checking this first, and seeing if you can get it to work over http

Thanks Nic, turns out the problem was SSL, imported the certificate into OpsHub and everything appears to be working correctly now.

Paul, hope your problem was resolved. If you find any other issues feel free to reach out to us. Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 14, 2019 in Jira

Updates to jira.atlassian.com give you visibility into what's coming in Jira Server and Data Center

Hello, Community! My name is Gosia and I'm a Product Manager on Jira Server and Data Center here at Atlassian. Since 2002 when we launched our public issue tracker, jira.atlass...

715 views 1 15
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you