Receiving subscriptions for deleted filters..how to fix this?

sn September 18, 2017

hi all,

users of JIRA software 7.3 server. 

user accidentally created a filter added subscription to email the results to all users in JIRA. when we approached the user, he deleted the filter but we are still receiving the email which is sent to all 400 users. this is very annoying. 

we use Oracle. i think there is no way to stop these without going to the DB.

please suggest.

thanks!

1 answer

0 votes
somethingblue
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
September 18, 2017

Hi,

There is actually a knowledge base article for this titled Keep receiving subscription emails from deleted filters that may help:

Diagnosis

Run the following query and check if the filter still in the database:

SELECT * from searchrequest where filtername = '<name_of_filter>';

(info) All queries are written for MySQL.

This query will show all the filters which have subscriptions, it will show the id and name of the filter:

SELECT fs.id, fs.filter_i_d, sr.id, sr.filtername from filtersubscription fs, searchrequest sr where sr.id=fs.filter_i_d;

Cause

If the query shows a filter with the name you indicate, this means the filter still exist in your database but not in JIRA UI, it means it hasn't been deleted successfully. 

Note: If the deleted filter did not appear in database table 'filtersubscription', there will be no emails send out from current JIRA regarding this filter. In this case, you need to check if you have another instance running on the same database.

Resolution

(info) Always backup your data by using the database backup tool before you do any changes to your database.

  1. Run the following query to delete the filter:
    • delete from filtersubscription where filter_i_d = (select id from searchrequest where filtername = '<name_of_filter>');
  2. Restart JIRA and do a Re-index (Administration > System > Index)

Cheers,

Branden

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