Rapid Boards Disappeared after Greenhopper 6.0.2 - 6.0.4 Upgrade; RapidViewAO with key XXXX not found

I upgraded Greenhopper 6.0.2 to 6.0.4 last night using the UPM. My rapid boards disappeared afterwards. I checked the table AO_60DB71_RapidView and saw my boards there.

I attempted a Re-Index (as suggested by Jira, I've also seen a similar issue after importing a project). The Re-Index failed declaring table AO_ISSUERANKING already existed.

java.sql.SQLException: There is already an object named 'AO_60DB71_ISSUERANKING' in the database.

I have seen this before with re-indexing and other AO_* tables. The AO_* appear to be tables generated by the indexer (why else would it try to create them?), so I removed all tables from the database which start with AO_ and I was able to successfully Re-index; the re-indexer recreating these tables as well.

Still no Rapid Boards. I tried uninstalling the plugin, reinstalling it, re-indexing (same issues as above to reindex); restarting, re-indexing (above method) did not work either. I discovered the table AO_60DB71_RapidView was not being repopulated with the re-index. I was also suprised to see in the logs the following exception thrown when I clicked on the Agile button.

java.sql.SQLException: There is already an object named 'AO_60DB71_ISSUERANKING' in the database.

and

2012-10-11 11:44:26,782 http-8080-5 WARN pwagner_local 704x146x1 1v42380 10.41.80.47 /rest/api/1.0/menus/greenhopper_menu [service.rapid.view.RapidViewDao] could not find entity of type interface com.atlassian.greenhopper.service.rapid.view.RapidViewAO with key 7

So something someplace knew I had rapid boards; but it could not load them.

I tried installing 6.0.5 too; no luck; rolled back to 6.0.2; no luck. I eventually succumbed to recreating the Rapid Boards manually and recreating the sprints which were active by using information from the change field tables looking for where the Field Sprint had changed.

I'd like to know what happened and how I can prevent it from occurring again? Or how to fix it? I want to upgrade Greenhopper however I do not want to loose the rapid boards again.

I found this recent post (https://confluence.atlassian.com/display/GHKB/could+not+find+entity+of+type+interface+com.atlassian.greenhopper.service.rapid.view.RapidViewAO+with+key+XX) as well as this one ( https://answers.atlassian.com/questions/91344/greenhopper-missing-rapid-views) to acknowledge others had a similar issue.

1 answer

1 vote

In case you are still facing this problem, this is currently being tracked by our developer here:

https://jira.atlassian.com/browse/GHS-9591

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Apr 17, 2018 in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

816 views 2 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you