QMetry Plugin Configuration error

I am trying to integrate JIRA with QMetry. I have filled all required details like QMetry Service URL, User Name, Password etc and when I tried to "Test" it, the service url cannot be verified.

This is very urgent requirement and heartly very much appreciated for quick response.

Please find the attachment for reference.

Also, If anyone has clear cut execution steps, kindly share me.

 

2 answers

0 votes

I think you want to give us more detail on the errors you are getting (there's no attachment if you were thinking you had put details in there - Answers does this sometimes, silently drops attachments)

However, the "test" button is usually a good one, if it is failing the connection test, then either your credentials are incorrect, or the JIRA server cannot reach the QMetry server

Hi Nic, First of all many thanks for quick response. Now I have attached the error image. Kindly check and give me your suggestions. Also If you have any configuration steps kindly share me.

I'm assuming the x.xxx's in the url are really numbers, but that really does confirm what the test button is telling you. (Note that it's not testing the credentials, it's not actually getting that far!) Either the server cannot reach the url you have given, or there is no QMetry service running there. Check the config of your network and the QMetry setup on the target

Hi Nic, Yes, wantedly changed IP to xxx for security purpose. QMetry service is running and the URL worked before, now its not working. Do you think URL is not valid ? I have googled and couldn't find proper documentation. If you have any could you please share me.

I don't know what the problem is. All I can tell you is that the JIRA server cannot reach the QMetry server for some reason - it's either the network or that QMetry is not running on the url you have got. Try basic testing - can you reach that url in your browser? Can you log into the JIRA server and try reaching it from there? (Try curl or wget). What error message do you get on the server when you try it?

Yes, I tried through browser and I able to see content. Also as you suggested I have logged into JIRA and tried acccess it thro wget and it's connected but throws certificate error. Through browser also I got certificate error. Do you trust certificate error is the cause? Attaching another screeenshot for which certificate error.

Ok, yes, that covers it. Your servers can't talk to each other because of the certificates. In this case, it looks like the JIRA server is not presenting the right ones to the QMetry server. I suspect you need to import certificates into the Java keystore, but I'm not 100% sure from the errors you see.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

21,126 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you