Project specific fields - failing for admins

Hi There,

we're JIRA 6.3.12 with the Add-on at version 2.2.2.

My project administartors are not able to add optioons into project specific fields at this time.

I tested that this worked initially on 6.1.?? perhaps there is an issue with 6.3?

Please advise if I need to supply you additional debug information,

 

John

8 answers

This widget could not be displayed.

Is the Project Specific tab still shown? If not maybe you license is out of maintenance?

This widget could not be displayed.

Hi Holger,

our licence is valid and the tab displays OK.

I'm awaiting feedback from a.n.other user now to confirm my suspicions ...

The feature is now working for myself and a test user - I suspect that the error occurs only with a null options set / the first option creation and works once it has been initialised OK.

John

 

 

This widget could not be displayed.

Unfortunately this is not the case. I have a user, who is in the Project Administrator role for a project, when he attempts to add an option to the project specific field the screen is completely cleared and the option is not added to the list.

This widget could not be displayed.

Anything in JIRA logs? Any special on project key or submitted option value? The tab is shown correctly before submitting a new option value?

This widget could not be displayed.

The page is presented correctly and on submitting a new value it collapses.

We have default logging options and I do not see anything in the logs w.r.t the failure.

Oddly, last week I created a local user, assigned the user to be a project administrator and reproduced the error - nothing in the logs; this morning the feature is working for the test user - this made me think it was connected with a null list, however for the real user this is not the case.

Have you any advice on getting more detail into logs to help to diagnose this issue?

This widget could not be displayed.

Which one of of the three Project Specific custom field types are you using?

If it is just one user I would recommend waiting for a week for the next major release which includes several refactoring. 

This widget could not be displayed.

Your question on whether this impacts one user made me check ...

Works on Firefox and fails on IE

Now that I know this only exhibits on IE I can advise my user base if and when they encounter it.

Are you aware of anything in the new version that might address this?

John

This widget could not be displayed.

Yes, next release is a complete redesign of the configuration user interface. It is implemented with the same UI features of version and component management. See second screenshot at https://bitbucket.org/hski/projectspecificselectfield-public/issue/33/allow-sorting-of-values-on-the-project. Hopefully this release will fix your problem.

I never got down to root cause analysis, but https://bitbucket.org/hski/projectspecificselectfield-public/issue/31/project-administrators-cannot-add-new seems to be similar to your problem.

Best regards,
Holger

Version 2.3.0 is released. Would be nice if you could give feedback, if problem is solved. Thanks in advance! Best regards, Holger

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

154 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you