It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Project Gadget is not correctly displayed

Hello,

The project gadget on the dashboard only shows __MSG_gadget.project.title__ in header and

gadget.project.title.lead in body.

I found out, that this gadget does not stop loading. I've tried to recreate it, but without success.

Does anybody know how to fix this?

kind regards

Manuel

1 answer

0 votes
nic Community Leader Mar 21, 2016

Which project gadget is it?

I hope this helps to figure out what gadget I mean

/rest/gadgets/1.0/g/com.atlassian.jira.gadgets:project-gadget/gadgets/project-gadget.xml

and here a screenshot

project_gadget.PNG

nic Community Leader Mar 21, 2016

Ok, great.  I asked because there's a few gadgets around that could get called "project gadget".  This is the built-in Atlassian standard one, which rules out my first thought (a client had something similar with an add-on "project gadget", needed a later version of the add-on)

As the gadget is taking ages to load, could you tell us if you have loads of projects?  Just a rough idea of the number is fine - 5, 50, 500, 5000 etc?  I seem to remember that this gadget can struggle in large installations with loads of projects.

Could you test what happens if you add another copy of the gadget to the board, and also show us the configuration of the new one?

Finally, one other thing I seem to remember breaking this sometimes - do you have any project leads that are no longer with you and have been deleted?  If you do, can you swap the leads of the project to someone with an active account and try it again?

I only have 3 projects. I've checked the project lead of them and they are pointing to active users.

I've also added another copy of this gadget with following config:

project_gadget2.PNG

What number do you mean?

nic Community Leader Mar 21, 2016

3 projects is the number I was looking for.

The config of the gadget is fine, but I notice it's not loading any of the labels as well as the title.

Is it just this one gadget that is failing, or are any others showing labels instead of text?

As a quick test, could you try swapping your personal language selection in your profile to English (I'm assuming it's currently German).  Do the English labels come out?

ok, i've changed to englich but nothing changed.

there are also other plugins failing.

nic Community Leader Mar 21, 2016

Ok, then it's not the gadget, it's the whole of JIRA failing to load the i8n stuff correctly.

I'd start reading the logs to see if there are errors in there, but I'd also be tempted to clear the addon cache and restart it.

Hello, i've deleted the plugin cache and restarted JIRA as recommendet. But nothing changed.

And the only message i can find in logs is this one:
21-Mar-2016 15:24:36.641 WARNING [ajp-nio-8009-exec-11] com.sun.jersey.spi.container.servlet.WebComponent.filterFormParameters A servlet request, to the URI https://jira.joyn-it.at/rest/gadget/1.0/project/generate?projectsOrCategories=allprojects&showStats=false&_=1458570254903, contains form parameters in the request body but the request body has been consumed by the servlet or a servlet filter accessing the request parameters. Only resource methods using @FormParam will work as expected. Resource methods consuming the request body by other means will not work as expected.


nic Community Leader Apr 02, 2016

The other things I can think of are:

  1. What version of Java are you using
  2. What is the locale set for the JVM
  3. What language have you selected in your profile

Hi,

I am facing the same issue with gadget for JIRA 7.1.I am using Version of Java is 1.8.0_91."English" language I have selected in my profile.Please guide me how to resolve this issue.

 

 

nic Community Leader Aug 31, 2016

Is it all gadgets, some, or just this one?

I am having the same problem.  MSG_gadget.project.title shows up as title of gadget on my system dashboard.  "gadget.project.title.lead" is overwriting all of my project lead names.

nic Community Leader Sep 27, 2016

Generally the same answer - quite likely that your JIRA can't talk to itself.  Work through all the follow up questions (that people above have not bothered to respond to, hopefully because the question has lead them to see where the problem is, and hence fixed it)

I had the same issue. I figured out that it was caused by accessing JIRA by a URL which is not set as BASE URL internally. (For myself just the port was different.) When I changed the accessing URL to mach the Base URL the problem did not occur any longer.

Maybe this helps someone in the future.

nic Community Leader Nov 15, 2017

Yes, that would cause "Jira cannot talk to itself".

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Calling all Jira Cloud users! Give us feedback on our exploration of a new navigation.

Hi everyone! My name’s Matt and I’m a product manager at Atlassian. I work in the navigation & findability space for all our Jira Cloud products. We’ve been working on trying to improve the exp...

1,051 views 16 12
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you