Problems starting a new Jira plug in

I have been following these two guides and I've been having difficulties with the atlas-run step, no matter what I do it doesn't start the needed plugins. Any help would be appreciated.

https://developer.atlassian.com/docs/getting-started/set-up-the-atlassian-plugin-sdk-and-build-a-project/install-the-atlassian-sdk-on-a-windows-system

https://developer.atlassian.com/docs/getting-started/set-up-the-atlassian-plugin-sdk-and-build-a-project/create-a-helloworld-plugin-project

Version:1.0 StartHTML:000000212 EndHTML:000009982 StartFragment:000007604 EndFragment:000009844 StartSelection:000007604 EndSelection:000009830 SourceURL:http://adomasl-lenovo:2990/jira/secure/errors.jsp JIRA access problem

System plugins failed to start: We haven't been able to start all the required system plugins

We couldn't start the following plugins:

 

  • JIRA Projects Plugin (com.atlassian.jira.jira-projects-plugin)
  • Atlassian OAuth Consumer Plugin (com.atlassian.oauth.consumer)
  • Atlassian Navigation Links Plugin (com.atlassian.plugins.atlassian-nav-links-plugin)
  • Atlassian JIRA - Plugins - OAuth Service Provider SPI (com.atlassian.jira.oauth.serviceprovider)
  • Atlassian JIRA - Plugins - Project Config Plugin (com.atlassian.jira.jira-project-config-plugin)
  • Applinks - Plugin - Core (com.atlassian.applinks.applinks-plugin)
  • Atlassian OAuth Service Provider Plugin (com.atlassian.oauth.serviceprovider)
  • Embedded Gadgets Plugin (com.atlassian.gadgets.embedded)
  • Gadget Directory Plugin (com.atlassian.gadgets.directory)
  • Atlassian Plugins - JavaScript libraries (com.atlassian.plugin.jslibs)
  • Atlassian JIRA - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)
  • Atlassian JIRA - Plugins - Global Issue Navigator (com.atlassian.jira.jira-issue-nav-plugin)
  • Atlassian JIRA - Plugins - File viewer plugin (com.atlassian.jira.jira-fileviewer-plugin)
  • Atlassian Pretty URLs Plugin (com.atlassian.prettyurls.atlassian-pretty-urls-plugin)
  • Atlassian JIRA - Plugins - Quick Edit Plugin (com.atlassian.jira.jira-quick-edit-plugin)
  • Atlassian OAuth Admin Plugin (com.atlassian.oauth.admin)
  • Atlassian REST - Module Types (com.atlassian.plugins.rest.atlassian-rest-module)
  • Atlassian JIRA - Plugins - REST Plugin (com.atlassian.jira.rest)
  • Opensocial Plugin (com.atlassian.gadgets.opensocial)
  • atlassian-servlet-plugin (com.atlassian.web.atlassian-servlet-plugin)
  • Atlassian JIRA - Plugins - Look And Feel Logo Upload Plugin (com.atlassian.jira.lookandfeel)
  • Gadget Spec Publisher Plugin (com.atlassian.gadgets.publisher)
  • Atlassian JIRA - Plugins - OAuth Consumer SPI (com.atlassian.jira.oauth.consumer)
  • Atlassian JIRA - Plugins - SAL Plugin (com.atlassian.sal.jira)
  • Gadget Dashboard Plugin (com.atlassian.gadgets.dashboard)

 

1 answer

1 accepted

0 votes
Gonchik Tsymzhitov Community Champion Nov 30, 2017

Hello Adomas! 

 

Could you run: 

atlas-mvn clean

atlas-mvn package

If it works good. let's try again atlas-run

 

 

Cheers,

Gonchik Tsymzhitov 

Ran both of them successfully, unfortunately no effect :(

Okay, after commant atlas-mvn clean, your targer page has been purged. Could you double check it using explorer? 

And Could you clarify for which product  do you develop plugin?

Because I have reproduce, if I using some agile plugin functionality and then execure atlas-run. I got the same error.

Please, use this doc to set needfull product 

https://developer.atlassian.com/docs/advanced-topics/configure-amps-to-run-jira-core-with-additional-applications-installed

 

 

Stupidly I didn't notice my Java being the latest version (9) So I checked and it isn't supported. After reinstalling with the correct java version everything worked. Thank you regardless!

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,876 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot