Problem with attachment in Customer Portal when using mod_openam.so

Hi guys ,
I have a problem with the Customer Portal and mod_openam.so.
Jira is currently running behind an Apache that load, via virtualhost, the mod_openam.so module.
When this module is active, I cannot attach a file with size larger than 18kb and I get the error:

Java.lang.IllegalArgumentException: size should be a non-negative number. Got: -1
At com.atlassian.jira.util.dbc.Assertions.nonNegative (Assertions.java:230)
At com.atlassian.jira.issue.attachment.DefaultTemporaryWebAttachmentManager.createTemporaryWebAttachment (DefaultTemporaryWebAttachmentManager.java:90)

If I turn off the module, it's okay.

I have this error only if I attach the file via Customer Portal.

Any ideas?

Thank you!

1 answer

0 votes
Ann Worley Atlassian Team May 01, 2017

While researching support cases to look for precedents I found a ticket on which you are the reporter. One of your team mates commented on the ticket that the issue is resolved when you add:

SetEnv proxy-sendcl 0

to the configuration.

I understand the openam.so module is needed for integration with Forgerock OpenAM, so I am hoping someone with more familiarity with that will pipe up.

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 16, 2018 in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

1,288 views 17 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you