Post Function is not executing in JIRA 5.1.6

Hi,

We have a post function which is not executing in JIRA 5.1.6. In JIRA 4.4.4, it was working.

"The field fixers will take the value from Assignee"


Field fixers is a Multi User Picker type custom field.

Regards

Deepak Bhatia

3 answers

1 accepted

0 vote
Mizan Community Champion Dec 17, 2012

You must be using some plugin to set the value of fixers ... try to find out which plugin provides this post function but checking the installed plugins (most probably the suite utilities plugin which provide a copy to field from another field postfunction) then check if this plugin is compatible with the JIRA 5.1.6 . if not you will need to update the plugin.

@Mizan answer is correct if you are using JSU plugin or if your using ur own plugin check the log it should throwing some errors

JSU is installed 1.3.2 for JIRA 5.1.6

what is the error message displaying?

Mizan Community Champion Dec 17, 2012

Check the logs if you see any error mesage , also try recreating the postfunction i.e. delete the old one and create a new one . (Assuming the issue is not unassigned)

atlassian-jira.log.5:2012-12-11 09:48:58,768 http-8080-36 ERROR meenakshi.jakhmola 588x160589x1 1vwcnen 210.7.75.130 /secure/CommentAssignIssue.jspa [jsu.workflow.function.CopyValueFromOtherFieldPostFunction] Unable to copy value from field 'Assignee' to 'fixers'.
atlassian-jira.log.5:com.opensymphony.workflow.WorkflowException: Unable to copy value from field 'Assignee' to 'fixers'.

Mizan Community Champion Dec 17, 2012

Is this the only thing displayed ? Did you try to delete and recreate the postfunction ?

I tried deleting the line copy assignee field to the fixers field and then adding this again. But again it failed.

Mizan Community Champion Dec 17, 2012

check if all the modules of this plugin are enabled ...

All modules are updated

Mizan Community Champion Dec 19, 2012

Even i had faced a similar issue when i had upgraded a JIRA instance but in my case the plugin was disabled so it was not working .. Are you sure you get the same error in logs ? Is there any other thing after the above error message . Can you provide the list of postfunction the this transition ?

Yes in the log also I am getting same error....I have raised this to JSUL

The issue with the assignee has been resolved after upgrading the JSU plugin to 1.3.3, but now I'm facing a new problem:

Every time I try to create a new issue, just before submitting it I get the following error:

Error creating issue: An unknown exception occured executing Validator com.googlecode.jsu.workflow.validator.FieldsRequiredValidator@37cedb10: root cause: java.lang.NullPointerException

The issue with the assignee has been resolved after upgrading the JSU plugin to 1.3.3, but now I'm facing a new problem:

Every time I try to create a new issue, just before submitting it I get the following error:

Error creating issue: An unknown exception occured executing Validator com.googlecode.jsu.workflow.validator.FieldsRequiredValidator@37cedb10: root cause: java.lang.NullPointerException

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

201 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you