It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

OnDemand to Standalone problem: Error: Unable to find JIRA backup (entities.xml) inside of zip file

I'm trying to do an export/import situation from an OnDemand instance to a Standalone instance. I did the backup of the OnDemand and put the zip file in the imports directory for the standalone. Initially, I got an error of:

Error importing data: java.lang.IllegalArgumentException: [GenericDelegator.makeValue] could not find entity for entityName: PluginState

Looking around, I saw that this was a problem with the differing versions of JIRA involved (https://jira.atlassian.com/browse/JRA-34099). So I unzipped my backup, edited the entities.xml file, zipped up the directory and tried importing. This gave me the error message:

Error importing from zip file: "/Applications/JIRA/import/jb.zip". Error: Unable to find JIRA backup (entities.xml) inside of zip file: /Applications/JIRA/import/jb.zip

I unzipped and made sure that the file was actually present, that the permissions hadn't been changed. I rezipped and got the same error message. Looking around, I saw a suggestion that it might be caused by the size of the attachments in the backup (https://confluence.atlassian.com/display/ONDEMANDKB/Unable+To+Find+JIRA+Backup+(entities.xml)+Inside+Of+Zip+File+Error) . So I took the entities.xml file and the activeobjects.xml file and copied them to a separate directory and zipped it up and tried importing it and still saw the same error message.

Looking around further, I saw the suggestion that entities.xml might be renamed by anonymizing or might be improperly in a sub-folder (https://answers.atlassian.com/questions/102134/jira-migrate-data-from-ondemand-to-jira-standalone-install), but none of those are the case here.

Any suggestions?

2 answers

1 accepted

1 vote
Answer accepted

I eventually got an answer from the Support section. Here is a wrapup:

Zipping of the two files should be done directly, not in a folder:

zip backup.zip activeobjects.xml entities.xml

Then there was a problem from importing, due to SQL issues: https://confluence.atlassian.com/display/JIRAKB/SQL+Exception+when+Entering,+Updating+or+Importing+an+Issue+in+JIRA+with+MySQL+Due+to+Encoding
I
then adjusted the importing JIRA instance to utf-8. Then I had to adjust the MySQL instance collation tables to utf8_general_ci.

Finally, I was able to import the OnDemand instance into the standalone instance.

Matthew

Thanks 

"Zipping of the two files should be done directly, not in a folder"

0 votes

This is a bug in the current self-hosted versions of JIRA (6.0.5 and 6.0.6): https://jira.atlassian.com/browse/JRA-34099

There is a workaround detailed in the above bug report. It should be fixed by the time 6.0.7 comes out in several weeks.

Michael,

The workaround mentioned in JRA-34099 is the one I pointed to first in my original report. I unzipped the backup, edited the entities.xml file, rezipped and tried importing. That's when I got the message about not finding entities.xml. I am never presented with an opportunity to acknowledge the error of the index path and attachment path. It goes along trying to import and comes back with the error message about not finding the entities.xml file.

Matthew

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

The add-in you’ve been waiting for: Jira Cloud for Excel 🙌

Introducing Jira Cloud for Excel Here at the product integrations team at Atlassian, we are thrilled to announce the new Jira Cloud for Excel add-in! This add-in lets you export Jira data directly ...

872 views 6 24
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you