It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

NullPointerException when accessing JQL

Whenever I am trying to access "/issues/?jql="  I am getting 500 error and below is exception

Cause

Referer URL: http://localhost:8889/plugins/servlet/upm

com.atlassian.cache.CacheException: java.lang.NullPointerException
com.atlassian.cache.CacheException: java.lang.NullPointerException
	at com.atlassian.cache.memory.DelegatingCache$DelegatingLoadingCache.get(DelegatingCache.java:270)
	at com.atlassian.jira.issue.fields.config.persistence.CachedFieldConfigSchemePersister.getFieldConfigScheme(CachedFieldConfigSchemePersister.java:100)
	at com.atlassian.jira.issue.fields.config.manager.FieldConfigSchemeManagerImpl.getValue(FieldConfigSchemeManagerImpl.java:72)
	at com.atlassian.jira.issue.fields.config.manager.FieldConfigSchemeManagerImpl.getValue(FieldConfigSchemeManagerImpl.java:63)
	at com.atlassian.jira.issue.fields.config.manager.FieldConfigSchemeManagerImpl.getRelevantConfigScheme(FieldConfigSchemeManagerImpl.java:323)
	at com.atlassian.jira.issue.fields.config.manager.FieldConfigSchemeManagerImpl.getRelevantConfig(FieldConfigSchemeManagerImpl.java:293)
	at com.atlassian.jira.issue.fields.CustomFieldImpl.getRelevantConfig(CustomFieldImpl.java:670)
	at com.atlassian.jira.issue.fields.CustomFieldImpl.getReleventConfig(CustomFieldImpl.java:362)
	at com.atlassian.jira.issue.fields.CustomFieldImpl.isInScope(CustomFieldImpl.java:390)

.............

        

I don't find any exception when I navigate to FieldConfigurationSchemes in Administration but the above exception is thrown whenever I navigate to IssueNavigator by using this url  http://host:port/issues/?jql=

But I can browse any single issue independently.  How do I fix this?

 

Thanks

Krishnan

 

2 answers

Hi,

If I look at the stacktrace, there seems to be something wrong with your field configuration. You could try running the integrity checker (Administration > System > Integrity Checker) to see if that shows what the problem is.

Regards,

Geert

Passed all the integrity checks. there is no mention of Field configuration at all

Had a similar issue, where I was unable to search by any select lists.

There's probably something wrong in the database, for me it was select list options having value of "null" or "disabled" column being "null". So you'd have to look for nulls that shouldn't be there. 

select * FROM customfieldoption where customvalue is null OR disabled is null;

Might be something completely different. 

Also, after you cleaned up the nulls, make sure you clear the cache:

Back up, and then delete jira_home/caches/indexes/ folder. You might even want to try that first, might get lucky and find out that only the cache was messed up. 

 

Hi @krishnan2

I'm experiencing the same issue. Did you find any solution?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

The add-in you’ve been waiting for: Jira Cloud for Excel 🙌

Introducing Jira Cloud for Excel Here at the product integrations team at Atlassian, we are thrilled to announce the new Jira Cloud for Excel add-in! This add-in lets you export Jira data directly ...

872 views 6 24
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you