Not getting all the class type

Hi ,

I am not able to get all the JIRA build in class type under the package com.atlassian.jira.issue.customfields.impl

calsses missing are SelectSFType,MultiURLCFType etc.

3 answers

1 accepted

0 vote

Your pom.xml looks ok to begin with (I'm tempted to tell you to try enabling the "com.atlassian.jira" dependency in there and see if that helps, but I'm really not sure that's the right thing to do)

Your IDE should be able to help you with the first dependency (SelectCFType) by telling you what you need to import.

I have no idea about the second class, I don't know what you're trying to do with an unknown package?

I have uncommented the dependency for Jira-core section but still problem persists.

Second class is

TextAreaCFType . I wrongly gave the other name .

I am using

import com.atlassian.jira.issue.customfields.impl.SelectCFType

And my IDE is saying

"SelectCFType cannot be resolved to a type"

But when I m using

<font><font> </font></font>

import com.atlassian.jira.issue.customfields.impl.TextCFType

its working fine.

<font> </font>

So what are you importing in your code, and what does your IDE say about it?

Ok, I'm lost then, it looks fine to me.

I think there is something wrong with your libraries or project settings, or your code is trying to use the class in an inappropriate way, but I'm not sure which.

Try rebuilding the eclipse project after the jira-core dependency is enabled.

mvn eclipse:celan eclipse:eclipse

Refresh the project in Eclipse after that. See if it helps!

Thanks a lot....

U r a champ I must say....It worked perfectly...

Thanks again

0 vote

You're going to need to give us a lot more information.

What are you trying to do (there's so little information here, I don't know if you're trying to build Jira from source, debug something in it, debug a plugin, write a plugin etc)?

What have you set up to do it? SDK etc?

What documentation are you following?

I am trying to craete a plugin for which i need SelectCFType,MultiURLCFType classes.

I have used Atlassian SDK for the setup.

I have already created a plugin readOnlytextfield which was extending TectCFType which worked.

But I m not getting the above classes in the mentioned package.

Ok, for SelectCFType, you need to check your imports and version that you're aiming for (look in the pom.xml for those) - I ran into this when trying to upgrade something from v3.3 straight to 5.0

I've never heard of MultiURLCFType, and google hasn't either.

(New Text Document (2).txt)

Hi Am New to JIRA so can you help me please what should I do.I am using Jira 5. attaching my pom.xml file.

I had the same problem. Adding the jira-core dependancy worked for me as well. My POM was already set to Jira version 6.2.5, but needed the jira-core I guess.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

Meet the AUG leaders of Northern Virginia

@Rachel Wright (Jira Genie), @Billy Poggi (AUG NOVA, DC), and @Dana Jansen (Confluence Queen) are just some of the folks that lead one of the world's most active Atlassian User Group (AUG)....

125 views 4 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you