Not Found (404) when editing Conditions from Workflow diagram

Not Found (404)

Action 'com.atlassian.jira.web.action.admin.workflow.ViewWorkflowTransition' could not be instantiated - org.picocontainer.defaults.UnsatisfiableDependenciesException: com.atlassian.jira.web.action.admin.workflow.ViewWorkflowTransition doesn't have any satisfiable constructors. Unsatisfiable dependencies: [[interface com.atlassian.jira.workflow.JiraWorkflow, class com.opensymphony.workflow.loader.StepDescriptor, class com.opensymphony.workflow.loader.ActionDescriptor, interface com.atlassian.plugin.PluginAccessor, interface com.atlassian.jira.config.ConstantsManager, class com.atlassian.jira.util.CollectionReorderer, interface com.atlassian.jira.bc.workflow.WorkflowService], [interface com.atlassian.jira.workflow.JiraWorkflow, class com.opensymphony.workflow.loader.ActionDescriptor, interface com.atlassian.plugin.PluginAccessor, interface com.atlassian.jira.config.ConstantsManager, class com.atlassian.jira.util.CollectionReorderer, interface com.atlassian.jira.bc.workflow.WorkflowService]]

Could not find what you were looking for. Maybe you should raise an issue.

JIRA home

I encountered this issue during the course of editing workflows and transitions in JIRA 5.2 . I am not sure what condition caused this to happen. This began to occur for one particular workflow out of 4 that I created.

This error only appears when clicking View Conditions, View Validators or View Postconditions from the workflow diagram editor. From the Text editor, this error does not appear. However, conditions, validators, etc. that were already created and published have disappeared. Even if I create a new condition from the text side, when I go back to the diagram side and click view, I get the same (404). Strange.

Since two workflows were very similar, I was able to re-create the fouled up workflow from a functioning "similar" workflow as a workaround. This would be bad if it were to happened to a workflow that is very complex and unique. I would like to avoid that situation - or the situation of all of my workflows suddenly breaking in this fashion.

Has anyone ever encountered this?

Thank you,

Aaron

1 answer

Doing a fast search about this I found this documentation on atlassian confluence: https://confluence.atlassian.com/display/JIRAKB/Missing+Available+Workflow+Actions

And it looks like this guy had the same problem and had something to do with a plugin that wasn't updated:

https://answers.atlassian.com/questions/89691/workflow-condition-is-not-working

Hope this helps.

I have the following plugins installed:

  • issue-alternative-assignee
  • JIRA Subversion plugin
  • JIRA Suite Utilities
  • JIRA Workflow Sharing Plugin

It is possible that installing one of them has killed my existing workflow. I will be more careful.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,763 views 18 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you