NoClassDefFoundError when executing the plugin without rebooting server Edited

Hi,

I have a plugin which has a 3rd party dependency on it. I'm not able to load a class from a third party dependency jar and got an exception as below.

2017-10-24 03:37:44,260 http-nio-8080-exec-176 ERROR      [o.a.c.c.C.[.[localhost].[/].[action]] Servlet.service() for servlet [action] in context with path [] threw exception [Servlet execution threw an exception] with root cause
java.lang.NoClassDefFoundError: Could not initialize class

I got that exception only if I didn't reboot the jira server after installing the plugin.If I reboot the server the issue won't appear.

Can someone please help me to solve the issue?

Thank You.

 

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

421 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you