No issues in backlog

I created a scrum board for one of our projects. When the scrum board was created, the backlog reflects there are currently no issues in the backlog. There should be 11 issues that appear in the backlog. I have checked the filter, columns (everything is mapped), and have checked to make sure its set to Global Context (which it is). I have searched the boards for an answer, but nothing seems to fix/or help. We also have a trial version on a different server running and the setup are exact and in this one we can see the backlog with no problems. We are using JIRA v5.2.5 and Greenhopper v6.1.2. Any help would be much appreciated, thanks in advance.

3 answers

1 accepted

Our problem has been fixed, it was a pretty easy fix. Just thought I'd share it with others, who might have a smiliar issue.

After double checking the following were right:

    • Set the Sprint's custom field contexts to 'Global' or to the projects to be used in GreenHopper
    • Set the Sprint's custom fieldSearchTemplatetoGreenHopper Sprint Field Searcher
    • Map the columns in board's configuration to the correct JIRA Status
    • Make sure there are no issues blocked by the board's filter

The one that was wrong was that the sprint custom field was hidden, after changing it to show and re-indexing JIRA, it fixed the problem. The backlog now showed all the issues.

    • Make sure the sprint custom field is not hidden in the Field Configurations page
    • Make sure that JIRA is re-indexed (Full Reindex)

I can't adjust the "Sprint" field in {{/secure/admin/ViewCustomFields.jspa}} because its "LOCKED". But that's 3 years later.

Thanks for the article. This one was very helpful: https://confluence.atlassian.com/display/GHKB/Backlog+is+Empty+in+The+Scrum+Board.

It fixed the problem after doublechecking some of the resolutions they listed.

1 vote
Ivan Tse Atlassian Team Feb 26, 2013

When you first installed Greenhopper did you perform a full re-index? Open one of the 11 issues that are supposed to be in the backlog, click "More Actions" drop down, then click "Rank to Top".

If the issue shows up in your backlog then I suspect that your indexes are out of sync. In that case, you should run a full system re-index (lock JIRA and re-build index option). That will effectively lock out all users, so you should do it at a off time.

Thanks for the response, but it didn't fix the problem. It was just a simple fix of changing the sprint custom field to "show" since it was set to hidden and then did a re-index.

This fixed my problem. Thank you.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

179 views 1 17
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you