Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

No Excel export of issues in search results after 7.3.0 update

This question is in reference to Atlassian Documentation: Working with search results

Since the update to 7.3.0, we're missing the "Export to Excel" menu item. Do we have to enable it somewhere somehow?

7 answers

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

I was hoping that the answer at the bottom of this page would help https://confluence.atlassian.com/jirakb/jira-excel-export-of-issues-no-longer-opens-correctly-838403242.html

It does not. (Not for me, anyway.)

Thanks for the link, I need to test this.

But why does the documentation still talk about the Excel export for 7.3.0 if it has been disabled since 7.2 already? Seems like a cut&paste error of the JIRA documentation team sad

And regarding the link you shared. It says at the bottom " we've introduced a more robust, flexible exporter in the CSV export". How in the world is this CSV export mor flexible?!? When I export my search results, I have multiple commas in the title, description, error message, time protocol and comment fields. That screws up the whole file completely and renders it useless.

Is it possible to configure the CSV export somehow so that the export is usable again? Or am I using this feature incorrectly?

All the CSV should do is separate column headers. Commas in your output should not matter. Can  you show an example of the erroneous export in screenshot?

Sure. I've constructed an example that's close to a real world example.

While doing so, I noticed that Excel doesn't recognize the comma separation at first. But if you force the comma separator on it, the import works. So far, so good. Unless, there are newlines, e.g. in the description. In that case, that issue is torn into multiple lines:

excel-import-mess.jpg

Therefore, my original claim stands: the CSV export is either unusable or I'm doing something wrong.

Here's the original file I used as Excel import:

I agree  , columns which have multiple fields or tags become seperated in the csv into their own columns...vs staying in their own column under excel...so filtering..etc. is not possible.

further tests showed that this might be a problem of Excel rather of JIRA/Atlassian. I've tried PlanMaker Viewer and it imports the CSV correctly. So does OpenOffice. Only Excel can't handle a mix of LFs and CRs/LFs (the special non-viewable characters that tell a word processor to break a line).

 

Either way, the old Excel export worked better with Excel. CSV might be more flexible but has its own problems when it comes to Excel. I suspect, though, that Atlassian can't do anything about it.

My current workaround is as follows:

  1. Export CSV
  2. Open it in OpenOffice
  3. Save file as XLS file out of OpenOffice
  4. Open XLS file in Excel

That way I can work with the file again as intended. Too bad it adds another step and another program, but it beats having to add the data manually each week to my Excel report smile

 

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you