It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

MySQL Install, "Cannot add user, all the user directories are read-only."

We're moving JIRA to a new server. During the installation process at the Set up administrator account we're getting the following error:

  •     Cannot add user, all the user directories are read-only.

We tried deleting everything and starting over with the default database (not MySQL). Installation went ok.

But again, when reinstalling using MySQL the error returned.

We are copying the java driver to jira's lib folder. JIRA installation process is able to connect and create the required tables. JIRA database user has been granted all permissions to the database. I checked the logs on /var/atlassian/application-data/jira/log/ and /opt/atlassian/jira/logs and cannot find anything in them. MySQL logs are empty.

Process is running with user jira. I checked that the directories owner is jira. JIRA version on new server is the latest. Java version is Oracle's 1.8.0_60. MySQL version:  5.6.25-0ubuntu0.15.04.1 and MySQL Java connector: 5.1.37.

I don't know what else to check.

Please help us,


8 answers

1 accepted

0 votes
Answer accepted


We solved our issue by using the Built In database connection. When the installation was done, we restored the data from our previous installation via the JIRA Administration > System panel. We'll migrate later to MySQL using the following procedure:


You will still need to fix whatever it is that stopped you from creating the directories. The built-in database is NOT a solution, and you'll need to fix the root cause when you migrate (and remember the built in database is not suitable for production too)

I had the same problem during installation in an empty mySql db using JIRA 7.0.5

I could not figure out the cause as all logs seemed to be clean.

But restarting the setup by jumping back to worked for me.

Sure it's no fix, but as it seems this also worked for Slawomir and can be used as a workaround.

This worked for me too.

In other words, starting clean and setting it up properly worked.


0 votes

This actually looks like it's something to do with the user directories, but start with the basics.  You've covered most of what I'd want to ask already, but...

Is the MySQL database you are trying to connect to empty?  If not, then what is in it?  Your existing JIRA data from the old server?

Thanks Nic,

Yes, it is a new database. I created it right before starting the installation with the following commands:


create user 'SomeUser'@'localhost' identified by 'SomePassword';

create database SomeDatabase character set utf8 collate utf8_bin;

grant all privileges on SomeDatabase.* to 'SomeUser'@'localhost';

flush privileges;


I can see that the previous installation step successfully has created many tables in it.


Ok, that's a start. After the installation failed, what can you see in that database? Has it done anything at all? Also, has it asked you what type of user directory you want to run with? If it has, what did you ask it to do?

Had the same error. Tried few things but I believe opening JIRA ports in the firewall solved the issue.

Edit: after installing again with firewall configured, it happened again. I've restarted firewall, JIRA service and opened setup in new tab, which helped.

Just ran into this last night. Asked support, and I'm curious. Does the new server use MariaDB, instead of MySQL?

I have ran into this issue as well on Gentoo linux, using mysql 5.5.42.  After reviewing the log files it looks like this is related to the BINLOG_FORMAT in mysql's config file (my.cnf)

Caused by: java.sql.SQLException: Cannot execute statement: impossible to write to binary log since BINLOG_FORMAT = STATEMENT and at least one table uses a storage engine limited to row-based logging. InnoDB is limited to row-logging when transaction isolation level is READ COMMITTED or READ UNCOMMITTED.


I updated my.cnf, specifically adding the fowllowing line under the [mysqld] section:

binlog_format = MIXED

Then, restart mysql.  After that, go back to your JIRA web interface and start over.  I was able to get passed the screen and continue my install / setup.


I am having the same problem. Can some please properly solve this!

0 votes

It's the same answer - your database is not set up correctly and you need to grant the correct read/write access to the JIRA user.

Net Admin bodged it by using a different database and then setting up a new one correctly, instead of fixing the broken database.

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you