My JIRA (data center) logs lot of "The encoding [binary] is not recognised by the JRE"

GINIBRE Sylvain
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 17, 2024

My Jira instance behind a reverse proxy (HAPRoxy) was running like a charm until we made the last upgrade to 9.12.5.

Now there are lot of WARNING like :
org.apache.catalina.connector.Response.setContentType The encoding [binary] is not recognised by the JRE

Did not find any information about that warning ...

1 answer

0 votes
Harald Seyr
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
April 17, 2024

Hi @GINIBRE Sylvain 

This seems to be a known bug, see [JRASERVER-71265] "The encoding [binary] is not recognised by the JRE" keeps getting logged in Tomcat log - Create and track feature requests for Atlassian products.

Apparently, this is a known issue that is yet unresolved. The recommended workaround to simply disable all warnings in logs by setting log level to error seems pretty drastic to me.

Maybe you add a note to the issue increasing the chance that someone at Atlassian picks it up.

Also, a note in Solved: JIRA is running in Windows server and is giving me... (atlassian.com) seems to indicate that this warning can be caused by using a JRE not supported by JIRA, so maybe changing your JRE will solve this.

Regards,

Harald

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
AUG Leaders

Atlassian Community Events