It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Mobile app does not work with my account Edited

We use SAML authentication and we have multiple techs configured on Jira exactly the same way. Others can use the mobile app but my account will not work. I am using the pixel 3 and also had another tech sign into my phone with their account and it worked. When I attempt to sign in, I am redirected to the SAML authentication page and then after successful sign in, it takes me back to the original login page. Any ideas on what to look at?

1 answer

1 accepted

1 vote
Answer accepted
claud Atlassian Team Feb 11, 2019

Hey Casey,

 

It looks like you are running into a known bug. Please see it below:

https://jira.atlassian.com/browse/ID-6658 

Most likely, your account has a different email domain than the ones of your colleagues and that's why you are redirected to the SAML SSO section. This is currently unsupported / not working in the mobile apps.

Claudiu 

Thanks for the response Claudiu. This does not appear to be the issue I am having. We are using ADFS for SAML. I confirmed that my UPN and primary SMTP address is correct in AD. I do not see anything different right off the bat between my account and one that is working. We are passing the following attributes in ADFS: Given-Name, Surname, UPN, and E-mail address (as Email). All of those appear fine on my account. The co-worker in charge of the atlassian service desk deployment project wants to try to to remove my account and re-add it to see if it makes a difference.  I will post back if that makes a difference.

So interestingly enough, we were about to delete my account and we decided to try my account on an iphone and it worked. So we went back to my phone (Pixel 3), and tried it again and it did not work. 

I then attempted to sign up, typed in my email, name, and a random password and clicked continue. Went through the captcha and then it redirected me to my SAML login. I then signed in with my SAML credentials and I was able to sign into the app without any issues.

Not sure what the issue is exactly, but I was able to sign into the app that way.

claud Atlassian Team Feb 11, 2019

That's odd, but glad to see it's working now.

Like cgorman likes this

Our entire company has the same problem with the Jira Mobile apps. We are setup with Google Apps SAML. Whenever we try to login as Google, it kicks us out with the error "invalid credentials" I tried to use the sign up workaround above and still get the same error, as the mobile app (jira, confluence) detects again that it is a Google account and forces us the sign in that way.

 

There are no issues when logging in from the web. This issue has been around since at least July when we started using Atlassian.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

334 views 1 3
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you