Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Manual upgrade of Jira Server leads to Setup Wizard

Hi everyone,

I performed a manual upgrade of Jira Server based on Atlassian documentation and Atlassian support instruction. When I run Jira post-upgrade, I get the setup wizard (SetupMode!default.jspa) instead of the upgrade success page. I need to either get to the upgrade success page or revert back and run my old instance of Jira as it was, but whether I run the new or old version of Jira (via ./start-jira.sh), the result is the same: the setup wizard.

Any help would be appreciated.

1 answer

0 votes

It would seem that perhaps Jira is not finding your jira-home directory.

How were you specifying that before? Using the JIRA_HOME environment variable?

If unsure, you can try to set it in the <jira_install_dir>/atlassian-jira/WEB-INF/classes/jira-application.properties

Hi Peter, and thank you. I have JIRA_HOME set in several places (all to the same path), including in jira-application.properties. I have checked directory permissions, dbconfig.xml file existence and permissions, etc. - but Jira just keeps showing me the setup screen when I stop and start it. I tried this, too: https://community.atlassian.com/t5/Jira-Software-questions/How-do-I-use-my-renewed-license-with-the-existing-server/qaq-p/1417671

Any other ideas?

Review catalina.out, you might get some clues.

Also look for hidden files in jira-home. If you see an empty file called .jira-home.lock (and with a created date that matches your start time) that means that jira found the jira-home and is using it. Then you can further review the <jira-home>/log/atlassian-jira.log

If the file is not there, the startup didn't identify the jira-home directory or didn't have access to it.

Like AMI I_T likes this

The lock file is indeed present, so that rules out a pathing issue. The log shows that the dbconfig.xml file is being read, but then there's a message that "The database is not yet configured". I know the db is configured because we've been using it for a long time, and I've inspected the dbconfig.xml file and everything looks correct.

 

Here's the tail of the atlassian-jira.log file that shows the db issue:

 

2021-04-24 18:20:01,454-0600 JIRA-Bootstrap INFO [c.a.j.config.database.SystemDatabaseConfigurationLoader] Reading database configuration from /srv/jira/jira-data/dbconfig.xml
2021-04-24 18:20:01,475-0600 JIRA-Bootstrap INFO [c.a.j.instrumentation.external.DatabaseExternalGauges] Installing DBCP monitoring instruments: DatabaseExternalGauges.JiraDbcpInstruments[instruments=[DBCP_MAX, DBCP_ACTIVE, DBCP_IDLE],objectName=com.atlassian.jira:name=BasicDataSource]
2021-04-24 18:20:01,556-0600 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger] Running Jira startup checks.
2021-04-24 18:20:01,557-0600 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger] Jira pre-database startup checks completed successfully.
2021-04-24 18:20:01,613-0600 JIRA-Bootstrap INFO [c.a.j.config.database.DatabaseConfigurationManagerImpl] The database is not yet configured. Enqueuing Database Checklist Launcher on post-database-configured-but-pre-database-activated queue
2021-04-24 18:20:01,614-0600 JIRA-Bootstrap INFO [c.a.j.config.database.DatabaseConfigurationManagerImpl] The database is not yet configured. Enqueuing Post database-configuration launchers on post-database-activated queue
2021-04-24 18:20:01,621-0600 JIRA-Bootstrap INFO [c.a.jira.startup.LauncherContextListener] Startup is complete. Jira is ready to serve.

Next thing to check is to make sure that the process has access to the dbconfig.xml file.

What user is your process running as? Who owns the dbconfig and what's the permission mask?
Can you confirm that the jira user can read the file?

This is what I see:

-rwxr-xr-x. 1 jira jira 739 Apr 22 10:32 dbconfig.xml

I'm currently running Jira from a command line while logged in as root.

Depending on how it was setup before, it's possible there is some user impersonation set up.

After you star jira, can you confirm who owns the java process?

$ ps -ef |grep jira

jira 11639 1 99 19:13 ? 00:00:28 /srv/jira/jira-home/jre//bin/java -Djava.util.logging.config.file=/srv/jira/jira-home/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Xms1024m -Xmx2048m -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Dorg.dom4j.factory=com.atlassian.core.xml.InterningDocumentFactory -XX:+PrintGCDateStamps -XX:-OmitStackTraceInFastThrow -Djira.home=/srv/jira/jira-data -Datlassian.plugins.startup.options= -Djdk.tls.ephemeralDHKeySize=2048 -Djava.protocol.handler.pkgs=org.apache.catalina.webresources -classpath /srv/jira/jira-home/bin/bootstrap.jar:/srv/jira/jira-home/bin/tomcat-juli.jar -Dcatalina.base=/srv/jira/jira-home -Dcatalina.home=/srv/jira/jira-home -Djava.io.tmpdir=/srv/jira/jira-home/temp org.apache.catalina.startup.Bootstrap start
root 11709 2945 0 19:13 pts/2 00:00:00 grep jira

So while you are root while running, the startup routine changes the user to "jira" (the first column).

But that shouldn't matter since the dbconfig is owned by jira and the owner has read and write permission (the first rw in -rwxr-xr-x)

You can be sure by running: 

$ runuser jira -c 'cat /srv/jira/jira-data/dbconfig.xml'

That command shows the contents of the dbconfig.xml file successfully.

I'm not sure what to try next.

Are you sure your DB is compatible with the newer version of jira?

Do you have the correct .jar file for the dbengine you are using? For example, jira doesn't ship with a mysql driver. You have to install that in <jira-install>/lib

It's a Postgres db and it was working a day or two ago.

The strange thing is that I'm seeing the setup wizard when I run the new OR the old version of Jira. I see in the console that the version I'm expecting is running actually is, but the end result appears to be the same.

Thank you for your help today. I really appreciate it.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you