Lost Admin Rights using JIRA with Crowd

I'm using JIRA (v6.2#6252-sha1:aa34325), everything has been working perfectly except that when I just tried to authenticate as admin I keep getting a message "The password you entered is incorrect."  It's integrated with CROWD and I have the group of jira-administrators assigned to my user.  This was working for months but now I can no longer login as admin.  Here is the output from the atlassian-jira-security.log, as you can see it passes authentication when logging in, but fails with the same user attempting to elevate to admin.

2014-09-20 22:13:54,308 http-bio-8380-exec-9 USER 1333x226x1 mzhk7k x.x.x.x,127.0.0.1 / The user 'USER' has PASSED authentication.

2014-09-20 22:14:23,760 http-bio-8380-exec-9 USER 1334x258x1 mzhk7k x.x.x.x127.0.0.1 /secure/admin/WebSudoAuthenticate.jspa The user 'USER' has FAILED authentication.  Failure count equals 1

I've found this in the crowd logs:

2014-09-20 22:55:23,872 http-bio-8095-exec-19 INFO [plugin.rest.filter.BasicApplicationAuthenticationFilter] Invalid authentication for application with name 'jira'

This only occurs when attempting to elevate the privileges to administrator, user login works fine.  The settings in crowd.properties are correct. 

Any thoughts?

1 answer

This widget could not be displayed.

Here's an update on this.  I had a special character '@' in my application.password.  I removed this and it is now working as expected.  Interestingly enough, the user authentication worked fine with this, but when attempting to elevate privs I would experiencing the issue.

I have SSO enabled via  com.atlassian.jira.security.login.SSOSeraphAuthenticator.

So, I suspect there is a bug in this particular use case.  To reproduce, use crowd with SSO enabled in Jira, with the @ sign at the end of your application.password attribute.  Sign in to JIRA with a user who has the group jira-administrators assigned to them in Crowd, and attempt to elevate to administrator.

 

This has bit me before but I didn't bother tracking down what was wrong with my password, just limited the 'special characters' to those most command line parsers accept. Thanks!

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

578 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you