Local JIRA will not start

This question is aimed at Administrators, however I am developer who sometimes poses as a JIRA administrator.

That being said, IT rebooted our JIRA server. Since then we have not been able to get JIRA to start. We have worked through several errors and finally got stumped with:

---------------------------------------------------------

The following plugins are required by JIRA, but have not been started:

  • Atlassian JIRA - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)

---------------------------------------------------------

How do I start this plugin? Thank you in advance.

5 answers

1 accepted

All,

Discovered some missing windows updates on the server. Aplied updates, rebooted and manually brought the SQL instance back up and all was magiclly fixed.

Thank you.

BTW the server that had to have updates applied was the SQL server not the JIRA server.

1 vote
Richie Gee Atlassian Team May 01, 2013

Hi there,

Can you help try to remove all the files inside the folders below?

<JIRA Home Directory>/plugins/.bundled-plugins

<JIRA Home Directory>/plugins/.osgi-plugins

And restart JIRA, no worries, it will be rebuilt upon restart, it seems to me like the gadget plugin is corrupted, hope this helps :) cheers

0 vote

It should start as the service starts. I think this failure is indicative of a more serious problem earlier in the startup.

What else does your log say?

How do I find the log?

Depends on how you configured Jira in the first place, but start with <whereever you told it "jira home" is>/logs

My log is filled with these:

2013-04-29 15:18:08,399 main WARN [core.entity.jdbc.DatabaseUtil] Entity "Action" has no table in the database

2013-04-29 15:18:08,436 main ERROR [core.entity.jdbc.DatabaseUtil] Could not create table "JIRA.jiraaction"

2013-04-29 15:18:08,436 main ERROR [core.entity.jdbc.DatabaseUtil] SQL Exception while executing the following:

CREATE TABLE JIRA.jiraaction (ID NUMERIC NOT NULL, issueid NUMERIC, AUTHOR NVARCHAR(255), actiontype NVARCHAR(255), actionlevel NVARCHAR(255), rolelevel NUMERIC, actionbody NTEXT, CREATED DATETIME, UPDATEAUTHOR NVARCHAR(255), UPDATED DATETIME, actionnum NUMERIC, CONSTRAINT PK_jiraaction PRIMARY KEY (ID))

and then:
2013-04-29 15:18:21,957 main WARN [atlassian.jira.security.GlobalPermissionsCache] Could not add permission Permission: [type=0][scheme=null][group=administrators][permType=group] - it already existed?
and then:
2013-04-29 15:20:51,214 Timer-0 WARN [internal.dependencies.startup.DependencyWaiterApplicationContextExecutor] Timeout occurred before finding service dependencies for [NonValidatingOsgiBundleXmlApplicationContext(bundle=com.atlassian.jira.gadgets-plugin, config=osgibundle:/META-INF/spring/*.xml)]
2013-04-29 15:20:51,239 Timer-0 ERROR [internal.dependencies.startup.DependencyWaiterApplicationContextExecutor] 2013-04-29 15:20:51,239 Timer-0 ERROR [internal.dependencies.startup.DependencyWaiterApplicationContextExecutor] Unable to create application context for [com.atlassian.jira.gadgets-plugin], unsatisfied dependencies: Dependency on [(objectClass=com.atlassian.gadgets.dashboard.DashboardService)] (from bean [&dashboardService])
org.springframework.context.ApplicationContextException: Application context initialization for 'com.atlassian.jira.gadgets-plugin' has timed out

Your database is broken! Possibly the connection settings, but Jira is missing tables there. Or, at least it can't read them, so it's trying to create what it needs (and then failing because the access is wrong)

You need to take a step back and get the database connection working before you'll get any further with this!

Ok the connection string is correct, the database is up and the username and password are correct.

I think I am going to raise a support issue at this point, because this was all working for over a year, and then just stopped.

Hi Jason,

I think this error you are facing may be relate to this KB (https://confluence.atlassian.com/display/JIRAKB/JIRA+System+Plugin+Timeout+While+Waiting+for+Plugins+to+Enable?utm_source=SAC&utm_medium=hercules-issue-view&utm_content=437849).

Please try the resolution suggested in the KB and see if that helps. :)

It looks like this may be the problem, as our disk drive is testing at being way to slow. Not sure how it worked before hand though. I am investigating to verify.

Hey Jason,

I think that maybe related to not enough memory, maybe you are running another application along with JIRA in the same server. As JIRA requires a lot of resrouces to startup. Maybe you would like to check whether there is any new application running at the same machine as JIRA that caused the problem.

Looking forward to hearing your updates. :)

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

243 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you