Linking Jira to Jenkins

Running Jira 6.1.7 with the Marvelution Jenkins plugin installed.

Latest Jenkins wiht the Marvelution Jira 1.3.3 plugin installed.

When trying to create the reciprocal link I get the following:

The remote application, 'Jenkins', is running an older version of the Application Links plugin. It will not be possible to create the remote end of the link from this application. However both ends of the link can be created using the older process in 'Jenkins'.

If I select 'no' to creating the reciprocal link then I can view builds in JIRA fine but even with a project link and issue key in our Git commits going through Jenkins nothing comes up on a project CI-builds tab and indeed the projects build number isn't incrementing trying a new sync.

Quite new to Jira so any help here appreciated.

11 answers

Ive updated to 1.4 on both and am getting Unable to create local link in response to reciprocal link creation request. on Jenkins. Duplicates remain. My ticket is unassigned should I just wait or update it with this??

Hi Craig,

I'm currently working on getting the Jenkins Application Links feature upgraded to support the newer JIRA version. Im nearly there and should be able to get a new version out this week.

Please keep an eye on the marketplace, this error will disappear once you have this version of the JIRA and Jenkins plugins installed. And this will also allow you and your users to use OAuth to integrate with Jenkins.

Cheers,
Mark Rekveld

Maybe you are effected by https://issues.jenkins-ci.org/browse/JENKINS-21954 Another user brought this to my attention, can you please check you Jenkins log

Thanks for pointing me at that, we did indeed need to downgrade our Git plugin from 2.0.3 to 2.0.1 to fix that issue. After a tweak of our proxy server settings i'm now seeing the CI builds linking to projects and issues correctly in Jira, many thanks.

Hi - I'm new to Jira and Jenkins as well and getting the same error and some strange duplications. I'm using Jira version 6.1.6 and Jenkins 1.544 with the lastest plugins for both (1.39 for Jenkins and 1.3.3 for Jira). I obtain the same error as Craig and can see the builds but I do however see some of the builds under the CI Builds tabs for certain projects.

My issue is the same as Craig's as per the application link is older in Jenkins error but I have triple Jenkins sites under Jenkins Configuration. Ive tried deleting and re-adding the configuration link to Jenkins but it just keeps adding to the list and I keep getting duplicates. Where would I go about removing all of them so I only have one? I only have one application link but several "sites" when I should only have one.

Would I have to change something around in mysql?

Thanks in advance for the help.

Hi Charlotte,

Please make sure that you have the JIRA plugin from the JIRA Jenkins Integration Project installed on your Jenkins site. The version of this plugin should match the JIRA plugin.

The duplication of sites is a new issue I haven't seen before. I'll run some tests and look into a possible fix for you.

Cheers, Mark

Hi Mark - I have the Jenkins for Jira plugin from Marvelution 1.3.3 installed on Jira is that the one you're referring to? I can see my builds but I get that same outdated app links on Jenkins error.. but the real nuisance is the duplicate sites. I cannot for the life of me delete them any way. Ive uninstalled the plugins and my application link is still there once I re-install the plugin. It seems to have stored everything in "memory" somewhere

Hi Charlotte,

Yes, the Jenkins Integration for JIRA project contains a plugin for JIRA (avilable in the marketplace) and a plugin for Jenkins. This Jenkins plugins implements the applinks framework of Atlassian for better integration. This plugin is available via Release Notes page in our Confluence instance.

I think this may also be the cause of your outdated duplicate sites. The JIRA plugin listens for Application Link actions and will manage the Jenkins Sites that way.

I'll add an action to the administration page to validate the Jenkins Sites configuration and remove Sites that are linked to nonexisting application links. This should solve your issue.

Cheers, Mark

Hi Mark, I've reinstalled the plugins 1.3.3 on both (I was using 1.3.3 previously and had installed another Jenkins jira plugin but was still getting errors), but I still get duplicates in the jenkins sites and still get the error that appl links on Jenkins are older...

Not sure if this also helps but when I remove the app link I get plugin errors and when I click to reinstall all the configuration (password etc.) is also there.

Hi Charlotte,

It looks like there is more going on on your system. Can you create a new bug issue at https://marvelution.atlassian.net/browse/JJI? Please include all details you have including log files. Than I can review those and see what the issue is.

I'm just about to release the new version with OAuth support and will take this up after you create the ticket.

Cheers, Mark

I've installed a new copy of Jira 6.2 and installed the new version of the Jenkins plugin in it. Without the plugin on the Jenkin's side I got no connectivity to produce a link, i'd thought that plugin was optional?

With the new 1.4 jira plugin within jenkins I can get the link working and showing the manifest.

The application link page is showing the following:

Application 'Jenkins' has been upgraded. Click here to Upgrade the Application Link configuration

If I click the 'Next' button it doesn't seem to do anything.

In the logs I also have:

2014-03-02 21:16:55,345 JenkinsConnectorExecutorServiceThread:thread-3 WARN craig 1275x290x1 594n6m 172.19.210.3 /secure/admin/RefreshJobList.jspa [jenkins.services.impl.RestCommunicator] No JSON response came from the server

for any attempt to reload build history.

Any thoughts on debugging this further would be appreciated.

https://jira.atlassian.com/browse/JRA-35003

The broken 'Next' button appears to be a wider issue and deleting and recreating the app link has created a perfect two way application link. I have also got a project link working perfectly.

However, the JSON errors in the logs remain and no build cache updates import any more builds. I am putting Jira keys in my Git commit messages which are linking back from Jenkins to Jira nicely.

I seem really close to getting this working now but not quite there.

Hi Charlotte, I saw the ticket but didn't have the time yet to respond. Other obligations toe away the time for Marvelution. I'll do my best to get back to you as soon as possible

Do you have a guide to how to use your plugin for Jenkins / JIRA integration:

e.g.

when to create the build

When to update JIRA with build info

When to generate release notes

When to mark JIRA version as released

I currently have JIRA Plugin installed: https://wiki.jenkins-ci.org/display/JENKINS/JIRA+Plugin, but I presume that this is a different solution.

I am willing to move to whichever tool, can give me the best view as to how the Jenkins / JIRA lifecycle can be best made to work. At present, neither of them appear to be particularly obvious, so this would be a good chance to highlight what I am missing.

Thanks

Hi Donald,

I don't have guides that show how to use the plugins. Currently there are basic configuration guides to get you started using the plugin in JIRA and Jenkins.

As for the Jenkins plugin you mentioned. That is the default Jenkins plugin. The Jenkins Inetrgation for JIRA project uses a custom plugin for Jenkins.

All documentation is available here https://marvelution.atlassian.net/wiki/display/JJI/Documentation+Home

And includes the release notes, feature overviews and configuration guides.

Let me know if this helps you out or if you need more.

Cheers, Mark

Suggest an answer

Log in or Join to answer
Community showcase
Pedro Felgueiras
Asked 36m ago in Jira

Clone a Zephyr issue

When I try to clone a Zephyr issue only a popup showing the issue id and nothing more shows.  On the browser console I see:  RTE not registered Error: No jira/editor/registry at c...

9 views 0 0
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot