Linked Confluence page still shows you do not have permission to view this page

I have set up Application Links between Jira 6.1 and Confluence 5.3 as descriped in the documentation. The IP Pattern i have left empty. Also using the public IP or does not work.

Confluence uses Jira as User Directory. Remote API (XML-RPC & SOAP) is checked in Confluence. Both instances are running on the same machine and we are using the system by using an public IP.

I can add a Confluence Page by using the Page URL and i can open the page from the JIRA Issue.

But in the Jira issue it is displayed as "You do not have permission to view this page"

Also when i try to search for confluence page, no pages are found and the combobox to select a space always displays "Loading...".

I have checked the Network traffice and i noticed that the call to "/rest/confluenceIssueLink/1/confluence/space?appId=5ba59816-2d6f-352d-b0d6-ce6e9cc5e5b5&_=1386747880239" always returns

{"errorMessages":["OK","java.lang.Exception: com.atlassian.confluence.rpc.NotPermittedException: Anonymous RPC access is disabled on this server"],"errors":{}}

So what have i to do to get it work?

3 answers

Hi Jehof,

Did you enable the remote api?

Best regards,


yes, Remote API (XML-RPC & SOAP) is checked in Confluence.

Hi Jehof,

Did you set up trusted authentication between the two applications?

Best regards,


I think i have set it up correctly. I can link to Jira Issue from a Confluence page (after i have fixed the URL Patterns). But i will check it again and come back with more information.

yes you should do that.

Best regards,


Do I need to turn on "Anonymous Access to Remote API" in Confluence to get it work?

I have checked my settings and verified that i have set up the Two Applications to Trust each other using Trusted Applications

Hi Peter,

with "Anonymous Access to Remote API" turned on, it works, but can you tell me why i need to turn on "Anonymous Access to Remote API" in Confluence? Should it not be enough to make them Trusted Applications and enable "Remote API (XML-RPC & SOAP)". I really don t want to allow "Anonymous Access" to Confluence. Can Jira not provided my current credentials to authenticate for the access

Hi Jehof,

I'm wondering, did you configure the trusted authentication for both incoming and outgoing links in both JIRA and Confluence?

Could you check this in both applications?

Best regards,


Yes, i have set it up for both. Do i also need to configure something on OAuth-Tab or Basic Access-Tab?

I have only made changes to the Trusted Applications-Tab

Hi Jehof,

Do you resolve your problem?

If yes, how?

Thank you

My problem solved since 2 months.

It's due to server base url in tomcat.

Cedric, was the solution that solved your issue differnet than turning on the Anonymous Access to Remote API ?

If so, please shed some light on the matter

0 votes
Ruchi Tandon Atlassian Team May 22, 2014

Ideally you do not ned to enable "Anonymous Access to Remote API". Do you have a proxy on your side? Can you check if the url that you get diverted to is the correct url? Is the base url for both applications : JIRA and Confluence set up correctly?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,919 views 19 22
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you