Link to Confluence is unstable

Hi,

our application link from JIRA to confluence works unstable.

- sometimes the spaces are not shown when you search for the page to link to (instead you can see only "loading" in the spaces menu)

- you can create a link only once, the second time the above problem appears

- the link in the issues is sometimes commented with "You do not have permission to view this page" but the user can access the page in confluence

JIRA and confluence are trusted applications and the users are ahred among both.

In the confluence log I' ve found this message:

2014-07-11 09:30:01,557 WARN [http-7090-6] [auth.trustedapps.filter.TrustedApplicationFilterAuthenticator] authenticate Failed to login trusted application: jira:10867595 due to: com.atlassian.security.auth.trustedapps.CertificateTooOldException: Certificate too old. Application: jira:10867595 Certificate Created: Fri Jul 11 09:29:42 CEST 2014 Timeout: 10000

Is there a way to cvhage the timeout?

Kinde regards

Frank

5 answers

This widget could not be displayed.

Frank,

Check your cert here, this error is related to JIRA thinking your Cert is for some reason incorrect: http://www.sslshopper.com/ssl-checker.html

Additionally, are you using "Trusted Applications" or OAuth for your authentication between the two? I believe you can change the timeout between the two during set up, too: https://confluence.atlassian.com/display/JIRA044/Configuring+OAuth+Authentication+for+an+Application+Link

This widget could not be displayed.

This is also happening to me. JIRA 6.2.5, Confluence 5.5.2, installed on the same server, behind a proxy, and with the application links done via plaintext/HTTP directly to the bundled Tomcat.

This cannot have anything to do with SSL certificates uses on the frontend.

EDIT: Certificate timeout is already at 0, it can't be clocks, and I'm trying to get OAuth working.

This widget could not be displayed.
Pedro Souza Atlassian Team Jul 11, 2014

Hello,

I believe you're facing the issue described on this article below:

https://confluence.atlassian.com/display/JIRAKB/CertificateTooOldException+when+Configuring+Trusted+Communication

Please, take a moment to try the suggested resolutions.

Cheers,

Pedro Souza.

This widget could not be displayed.

Update: I tried Atlassian's Application Links Diagnostic plugin but it didn't help and I wasn't impressed. In addition to it containing placeholder text from the SDK's example (e.g. published by Example Company), it just ate up memory and crashed JIRA.

I restarted both JIRA and Confluence, recreated the link a couple times and it started working on the fourth attempt, which was the first post-reboot one created from the Confluence side.

Frank, I hope this helps.

Hi Sean,

We are experiencing something very similar.

We are on Jira 6.2.7 and Confluence 4.3.7. we tried updating the timeout to 0 but doesn't work.

The Jira gadgets added on confluence pages return no data. They dont prompt an error either. They come up with " The filter for this gadget did not return any issues" .

But the same filters in Jira show data/issues. I have added all the Gadget URL's in Confluence under External Gadgets.

Frustrating as the logs show CertificateTooOldException but both applications are on the same server.


This widget could not be displayed.

Priya,

I honestly don't know why it suddenly started working for me, but try this, as it's what I did when it finally worked.

1. Delete the app link from the Confluence side, but DON'T delete the JIRA side

2. Delete the app link from the JIRA side, but allow it to try to delete the remote link (it'll fail since it's already gone)

3. Restart both JIRA and Confluence

4. Create the link from Confluence, then create the reiprical JIRA link from the same wizard.

Hopefully this helps.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

226 views 3 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you