LDAP setup not working after GreenHopper plugin is added

I have JIRA 4.2-m6 installed and configured to use an LDAP for login (I modified the osuser.xml accordingly). This all works fine until I stop the service and add the GreenHopper plugin (version 4.4). After the restart the login doesn't work anymore with LDAP (I can conect with only some users for which I know the password when they created the accounts locally). If I stop and remove the GH plug-in all works fine again.

1 answer

1 accepted

0 votes
Accepted answer

Hi there,

In theory Greenhopper plugin should't break the LDAP authenticate, but I noticed that you mentoned GreenHopper plugin version 4.4, I see this version is not compatible to JIRA 4.2. Possibly the LDAP authentication issue is just a side effect of another problem.

You may use a complatible version accordingly to the matrix in this link and see if it helps.

Cheers

Yes, looks like I was using the wrong version. It worked with GH 4.1. I solved the issue months ago by trial & error ...

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,417 views 15 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you