LDAP connections timeout

Hello,

I have a problem with idle connections to LDAP. Support tell me that I have to include "-Dcom.sun.jndi.ldap.connect.pool.timeout=3" in setenv.sh

My problem is that Tomcat seems to avoid this parameter. After restart I always see in System Properties: com.sun.jndi.ldap.connect.pool.timeout 0

I've tried to add also in setenv.sh other ldap parameters: -Dcom.sun.jndi.ldap.connect.pool.maxsize=20 and -Dcom.sun.jndi.ldap.connect.pool.debug=all but in that case I can see it in System Properties.

Am I missing something?

Regards.

Alberto


1 answer

Hi there!

If the tomcat is ignoring the parameter, this usually happens when you are running tomcat as a service.

In this case, please change this value on:HKEY_LOCAL_MACHINE -> SOFTWARE -> Apache Software Foundation -> Procrun 2.0 -> Crowd -> Parameters -> Java -> Options

For more information, please check this documentation.

Hi Guys,

I am having the same problem but on Linux.

I can't find if this has been addressed in later versions of JIRA.

Cheers

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

34 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you