Jira upgrade from 5.2 to 7.1.6 with Confluence 4.3.7

Presently JIRA 5.2 is working on https and linked (application links) to confluence 4.3.7 using CA signed SSL certificates. 

JIRA 5.2 is running  on java 1.7.0.51 with working SSL certificates imported in trust store of confluence.

I want to upgrade JIRA from 5.2 to 7.1.6. However confluence 4.3.7 will stay on same version until end of this month.

JIRA 7.1.6 needs Java 1.8.

Now

Will JIRA 7.1.6 work with Confluence 4.3.7 with application links using existing certificates ?

1 answer

Based on the APPLINKS matrix, it looks like this should work.  Application Links are very sensitive to SSL configuration, so be sure to include the intermediate cert in your configuration if your CA provides one. You're doing all this in a test environment prior to the production upgrade, right? smile

Personally, I'd move away from storing the certs in the Java keystore and configure an SSL proxy ahead of each app.  It's a pain to manage certs in Java and you need to bounce the app when you install a new cert.  If you use Apache or some other light weight proxy ahead of the app, you can bounce the proxy without humans even noticing.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,595 views 17 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you