Jira transaction log getting really big Edited

Haven't really been watching this, for the past 6 months or so, but noticed some server slowdown (MSSQL2012) and noticed that the Jira transaction log has skyrocketed to 650GB!  Any way to 'start over' with a new transaction log? 

Things I've noticed

the log file was set to autogrow (not really what I want) - I've since reset this, but that doesn't address my immediate problem


Things I've tried

Going into SQL Management Studio and trying to shrink - no joy there.  Kinda afraid to just delete it.

 

1 answer

Hi AJ,

There is a knowledge base by Microsoft that may help you with this issue titled Troubleshoot a Full Transaction Log (SQL Server Error 9002).  While your log is not full there are some mitigation steps listed:

The appropriate response to a full transaction log depends partly on what condition or conditions caused the log to fill.

To discover what is preventing log truncation in a given case, use the log_reuse_wait and log_reuse_wait_desc columns of the sys.database catalog view. For more information, see sys.databases (Transact-SQL). For descriptions of factors that can delay log truncation, see The Transaction Log (SQL Server).

Alternatives for responding to a full transaction log include:

  • Backing up the log.

  • Freeing disk space so that the log can automatically grow.

  • Moving the log file to a disk drive with sufficient space.

  • Increasing the size of a log file.

  • Adding a log file on a different disk.

  • Completing or killing a long-running transaction.

 

Take a look at the article for further instructions related to each step.  Hopefully that helps.

Cheers,

Branden

Well, don't know if any of that helped - you see I never got an error, I simply noticed slow performance and went looking for 'why'. That's when I discovered that the transaction log went bazinga.

I was able to clear the issue but I'm not really certain 'how' I did it.  I tried all sorts of things and was never able to actually delete the log when full recovery mode was enabled.  The transaction log kept growing to consume all resources.  it wasn't until I selected 'simple' recovery model that I was actually able to reduce the size of that log using 'shrink'.  Technically, that shouldn't have worked either.

I should note that nothing, adminstratively, changed in the way MSSQL was dealing with the jira database.  I have sinced configured the database to 'not' autogrow, so that the log wraps on itsself and re-enabled full recovery mode,

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,000 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot