Jira server cannot start 'unable to start the plugin container for confluence-roadmap-plugin'

I encounter the following problem during JIRA server startup. I am using JIRA server 6.2 version with postgresql. Previously it is working well. Just since last Friday it cannot be started, it is quite wired. I thought it might be because of the memory so I tried to increase the JVM_MAXIMUM_MEMORY but it is still the same. Please help.

The error message in the log is: 

 

ThreadPoolAsyncTaskExecutor::Thread 2 ERROR [plugin.osgi.factory.OsgiPlugin] Unable to start the plugin container for plugin com.atlassian.confluence.plugins.confluence-roadmap-plugin
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'roadmap-component' defined in URL [bundle://33.0:0/META-INF/spring/roadmap-context.xml]: Invocation of init method failed; nested exception is java.lang.NoClassDefFoundError: com/atlassian/confluence/macro/Macro
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1338)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:473)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory$1.run(AbstractAutowireCapableBeanFactory.java:409)
at java.security.AccessController.doPrivileged(Native Method)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:380)
at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:264)
at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:261)
at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:185)
at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:164)
at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:429)
at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728)
at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.access$1600(AbstractDelegatedExecutionApplicationContext.java:69)
at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$4.run(AbstractDelegatedExecutionApplicationContext.java:355)

1 answer

0 votes

What version of JAVA are you using for JIRA?

I am using java 1.7.0_65, I have tried to switched to java 1.6.0_34 and still have problem starting the server.

Oh, that could make it worse - stick with 1.7, the usual cause of this error is using an older unsupported version of Java. So, it's not the easy one, we need to look in more detail. The error is occurring when it is trying to load the "roadmap" addon, so that's the first thing to check. What version have you installed and are you sure that version is for Jira 6.2? How did you install it? Could you try cleaning the plugin cache and restarting Jira as well? - Make sure Jira is stopped - Go to your JIRA installation directory, find the "Work" directory and delete the contents. Do NOT delete the directory itself, just the content. - Go to your JIRA home directory and find the "plugins" sub-directory, In there, selete the '.osgi-plugins' and the '.bundled-plugins' folders (this forces JIRA to rebuild them on startup) - Startup your JIRA and check to see if the problem persists or the error changes

(Also, I'd like to see if it all runs ok if you run without the plugin)

Hi Nic, Thanks for your help. I have tried to delete the suggested contents and I manually enable all the plugins in the database (there are about 9 of them). Now I get the following error during startup saying some plugin time out. I have already changed the waiting time in bin/setenv.sh (JVM_SUPPORT_RECOMMENDED_ARGS="-DatLassian.plugins.enable.wait=500"). ___ FAILED PLUGIN REPORT _____________________ 9 plugins failed to load during JIRA startup. 'com.atlassian.jira.jira-quick-edit-plugin' - 'Atlassian JIRA - Plugins - Quick Edit Plugin' failed to load. Application context initialization for 'com.atlassian.jira.jira-quick-edit-plugin' has timed out It has the following missing service dependencies : &beanBuilderFactory of type (objectClass=com.atlassian.jira.rest.v2.issue.builder.BeanBuilderFactory) &beanBuilderFactory of type (objectClass=com.atlassian.jira.rest.v2.issue.builder.BeanBuilderFactory) It was loaded from /var/atlassian/application-data/jira-6.2/plugins/.bundled-plugins/jira-quick-edit-plugin-1.0.87.jar 'com.atlassian.jira.gadgets' - 'Atlassian JIRA - Plugins - Gadgets Plugin' failed to load. Application context initialization for 'com.atlassian.jira.gadgets-plugin' has timed out It has the following missing service dependencies : &outboundWhitelist of type (objectClass=com.atlassian.plugins.whitelist.OutboundWhitelist) &outboundWhitelist of type (objectClass=com.atlassian.plugins.whitelist.OutboundWhitelist) &externalWhitelistService of type (objectClass=com.atlassian.plugins.whitelist.WhitelistService) &externalWhitelistService of type (objectClass=com.atlassian.plugins.whitelist.WhitelistService) &gadgetViewFactory of type (objectClass=com.atlassian.gadgets.view.GadgetViewFactory) &gadgetViewFactory of type (objectClass=com.atlassian.gadgets.view.GadgetViewFactory) &dashboardService of type (objectClass=com.atlassian.gadgets.dashboard.DashboardService) &dashboardService of type (objectClass=com.atlassian.gadgets.dashboard.DashboardService) &gadgetRequestContextFactory of type (objectClass=com.atlassian.gadgets.GadgetRequestContextFactory) &gadgetRequestContextFactory of type (objectClass=com.atlassian.gadgets.GadgetRequestContextFactory) It was loaded from /var/atlassian/application-data/jira-6.2/plugins/.bundled-plugins/jira-gadgets-plugin-6.2.3.jar 'com.atlassian.administration.atlassian-admin-quicksearch-jira' - 'Atlassian - Administration - Quick Search - JIRA' failed to load. Application context initialization for 'com.atlassian.administration.atlassian-admin-quicksearch-jira' has timed out It has the following missing service dependencies : &sal-request-factory-import of type (objectClass=com.atlassian.sal.api.net.RequestFactory) &sal-request-factory-import of type (objectClass=com.atlassian.sal.api.net.RequestFactory)

The wait command is case sensitive, you'll need to get it spot on. If 500 fails, then you may have too little resources to get JIRA running on the machine - you could try 1000, but I'd be looking at the CPU and memory on the machine too - is it really up to spec?

Hi Nic, Thank you very much for your help. It turns out that it really is because of not having enough resource - in this case the CPU spec is too low. Previous we were using a single core CPU with 2 GB of memory. The memory should be enough but CPU is not powerful enough. I upgrade the server to 2 CPU core with 2GB of memory and now it is able to start successfully.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

471 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you