Jira seems to ignore Base Url


My JIRA software is installed on a host with a custom port http://JIRASERVER:8095 that is targeted by a reverse proxy configured as http://jira.myserver.com.

In the server option I set the base url to http://jira.myserver.com but JIRA keep sending attachments and images url as http://JIRASERVER:8095.

I installed the lastest JIRA version.

What can I try to do to solve the problem ?




2 answers

Make sure you configure the JIRA application base url to the relevant address:

Go to Admin->System->General Configuration

Click Edit Settings

Change Base URL

As you also wish to change the port from 8095 to 80 change server.xml:


<Service name="Catalina">
        <Connector port="8095"



SWorry but I don't have any "General Configuration" but "System".

I own JIRA software and not Confluence.

Anyway I already set the Base Url to the public one (http://jira.myserver.com) but it seems to ignore it and keep using the private one (http://JIRASERVER:8095)


If you don't have "general configuration", how are you setting the base url?

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,314 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot