Jira cloud API Failing on Free active version

Hello

Yesterday We have created free jira core instance.. We tried to consume User related api's like create user, update user, delete user and get user.

Those was working yesterday.. 

But today for same instance and same API's it's giving 500 internal server error.

We are reffering these api's

https://docs.atlassian.com/jira/REST/cloud/#api/2/user-createUser

https://docs.atlassian.com/jira/REST/cloud/#api/2/user-updateUser

https://docs.atlassian.com/jira/REST/cloud/#api/2/user-removeUser

https://docs.atlassian.com/jira/REST/cloud/#api/2/user-getUser

Only get user api is working today..

This issue is happening from 19th June 2017.. 

Please let me know how to resolve this issue.. Your help will be great for us..

Thanks

Varsha

1 answer

0 votes

Hi Varsha,

I contacted the Cloud team and they stated they are in the process of making some changes that may have affected this including the addition of additional features such as the fact Cloud is now using using Atlassian ID and have a bunch of other features private user, domain-verified only features, etc.

I can say that in my Cloud instance I ran into the same issue with the calls you mentioned so at this point I would contact the Cloud team to see if there is any additional information they can provide via a Support ticket.

Cheers,

Branden

 

Hi Branden

Thanks for reply, I just want to know that, is your cloud instance belonging to paid instance of free trial instance?

 

Thanks

Varsha

 

Hi Vasha,

Mine is a free instance as well.  I did ask if there is a difference in the way the free and paid versions would accept the REST calls and there shouldn't be any difference.  The Cloud Support Engineers I spoke to believe the primary reason we're experiencing this issue is due to some recent changes on the Cloud side.  I do not have all the details of the changes, however, there have been recent changes to the method of authentication, etc for Cloud which may be affecting the ability to make those calls.  In addition, they are also listed as Experimental methods:

Methods marked as experimental may change without an earlier notice. We are looking for your feedback for these methods.

At this point I would probably engage the Cloud team directly as they will be able to provide more specifics as to what changed, if the issue is due to the type of account you have, etc., however, I don't believe it's account related or anything of that sort as I am able to reproduce the same behavior but I dont have access to the Cloud backed to see why the calls are failing.

Thanks,

Branden

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,420 views 15 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you