Jira backup & project restore - incorrect versions of plugins stored in the backup xml.

I did an export of our data, deleted a project, and then tried to import the project again (after making some changes to the xml), and I was stopped by an error that Grasshopper & the Groovy plugins were older versions in the xml, and newer versions in our installed Jira.

Only ten minutes had elapsed since I did the export to when I tried the project import; and nobody upgraded anything. Looking closer, the lines in the xml are indeed wrong, these are not the versions that are currently installed:

<PluginVersion id="11200" name="Atlassian GreenHopper" key="com.pyxis.greenhopper.jira" version="6.1.5" created="2013-04-02 23:41:47.273"/> <-- We have 6.1.6 installed

<PluginVersion id="11400" name="Script Runner" key="com.onresolve.jira.groovy.groovyrunner" version="2.1.2" created="2013-04-02 23:41:47.293"/> <-- we have 2.1.3 installed.

I was able to get past this by editing the versions in the xml, and trying the import again. Did something go wrong in my last update of the plugin manager and Greenhopper/Groovy/et al?

I have a screenshot of the error, but I don't see how to attach screenshots to this system, just link to already hosted screenshots.

2 answers

1 accepted

This widget could not be displayed.
Ahmad Danial Atlassian Team Apr 18, 2013

Hey there, Kelly.

Could it be that plugin cache is not refreshed and therefore it is still storing the old plugin definitions? Let us try to flush out all the caches by performing the following steps:

  • Shutdown JIRA instance
  • Delete the contents of JIRA Home Directory\plugins\.osgi-plugins directory
  • Delete the contents of JIRA Home Directory\plugins\.bundled-plugins directory
  • Delete the contents of JIRA Installation Directory\work directory
  • Delete contents of the JIRA Home Directory\caches\indexes\changes directory
  • Delete contents of the JIRA Home Directory\caches\indexes\comments directory
  • Delete contents of the JIRA Home Directory\caches\indexes\entities directory
  • Delete contents of the JIRA Home Directory\caches\indexes\issues directory
  • Restart JIRA instance
  • Perform re-indexing

Hope this helps. Keep me posted on this matter.

Warm regards,

Danial

Thanks, I will try this.

This worked, thank you!

Ahmad Danial Atlassian Team May 08, 2013

Hey there, Kelly.

You are most welcome. Glad to be able to help!

Warm regards,

Danial

This widget could not be displayed.

Grasshopper ?!? yeap, it's a good nickname ...

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 18 hours ago in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

45 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you