Jira account missing after switching from HSQL to PostgreSQL

After installing JIRA and stepping through the Setup Application Properties wizard, one administrator account was created.  Using this account, about the only thing I have done was to install a plugin and licenses.  Now that my PostgreSQL database has been set up, I ran the config.sh tool to reconfigure the database.  I entered the database connection parameters and it test OK, so I saved the configuration changes.  Now when I try to log into JIRA, it wants to go through the Set Up Application Properties wizard again.  When I enter values and press Next, I get error:

Error adding service java.lang.IllegalArgumentException.  Multiple services with name "Backup Service" exist.

What do I need to do to convince JIRA that I have already run the wizard?  How do I log in if JIRA will not let me use the internal admin account that I already set up?

1 answer

1 accepted

Accepted Answer
0 votes

I am going to try running config.sh again to change the database back to HSQL, perform a backup, switch back to postgreSQL, and perform a restore. Is there a better way to fix this. Am I going to make matters worse by doing this?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

461 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you