Jira Unable to Send Mail after 5.2 upgrade

Hi,

I recently upgraded our Jira to 5.2 on a test linux server, it brought forward our existing SMTP configuration for outgoing mail, however the mail will not work, I can't even get the test mail to send.
Interestingly, the in-between upgrade to 4.4 (we were originally 4.1.2) was able to send the test mail successfully when I tried it.

The error given in the log upon trying to send the test mail is:

An error has occurred with sending the test email:
com.atlassian.mail.MailException: com.sun.mail.smtp.SMTPSendFailedException: 550 5.7.1 Client does not have permissions to send as this sender

(can provide full stack trace if needed)

Does anyone have any experience with this error or ideas on how to solve it?

Thanks,

Ethan

3 answers

1 accepted

1 vote

I have the same problem. Sending a test email works in JIRA 4.4, nothing to do with JIRA projects just at the email configuration. Upgrading to 5.2 produced the same error message. I reset the authentication credentials were are using with Exchange but the error still occurred. Test Connection reported no problems.

Removed authentication and it worked, so maybe I messed up the credentials?

Nope, the credentials work with the 4.4 instance. I also tried moving mail.jar and activation.jar from the JIRA lib dir to the Tomcat lib dir but no change in the error

Aha! Making the from address the same as the authentication user made this work. Looks like with JIRA 5.2 you can't send authenticated email via Exchange unless you make the sender the same as the Exchange user. Not sure how this will work with the per-project From addresses.

Great, thanks for your efforts Matt.

Can you just cross check whether you are using same user for authenticaion of your mail server and sending mail at project level?

Similar issue we faced. In our scenario we were authenticating with mail server using one id (ID1)and at the project level we used different id (ID2)for sending mails. so it thrown error.

Can you try to send a test mail from mail server config and check whether it is working fine. Then the problem from mail server.

You can ask your mail server team to grant permission to ID2 for sending mails as ID1.

Did you use Exchange? Maybe this link will help

http://blog.hodek.de/exchange-20105-7-1-client-does-not-have-permissions-to-send-as-this-sender/

Its german but in summary:

The problem is in the configuration of the mailaccount.
The account needs the permission to send mails as SELF.

Guido

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Apr 17, 2018 in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

807 views 2 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you