Jira / SpiraTeam Data Mapping - Permission Error

Hayden Ellison
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 10, 2024

Hello!

My team is currently looking to properly set up the JiraDataSync plugin between SpiraTeam and Jira in order to synchronize our products and incidents with both services.

We currently have an active Jira Cloud subscription, and the synchronization between Jira and SpiraTeam was working in the past (up until around late 2022) for our various products/project pages. Unfortunately, this is no longer the case, and we have been trying to troubleshoot the root cause of the issue to no avail. To troubleshoot this, we have tried things such as:

- looking through existing forums

- reaching out to Inflectra customer support (they have said it may be an issue on Atlassian's side)

- adjusting product mapping keys to match the related project in Jira

- adjusting user-level Jira IDs / JiraDataSync IDs within SpiraTeam (to ensure the user in SpiraTeam is linking back to the correct Jira user)

- adjusting the actual user used to set up the JiraDataSync plugin

The most progress we have made has been by re-enabling the service using the credentials of an admin-level user who seemingly has full access to the products/project pages in question. On the surface, it seems as if the synchronization is successful between the two services. However, once a SpiraTeam product is enabled (with its key matching the corresponding project in JIRA), we are met with an error (attached) that seems as if the user used to set up the service does not meet these permissions, despite seemingly being an admin with full control over the project in question. 

At this point, my team is stuck trying to figure out what the root cause of this issue might be. We have tried confirming the user used to set up the sync has the proper permissions to facilitate the synchronization, but the error received does not seem to offer much as to how to troubleshoot this or which Jira settings might need to be adjusted. 

Any recommendations as to how to go about fixing this issue would be greatly appreciated!

Screenshot 2024-05-10 102209.pngsync-error.png

1 answer

0 votes
Clark Everson
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
May 31, 2024

Hi @Hayden Ellison 

Welcome to community!

Looking at this, this tool is a testing suite. Generally for these you would need to have an app that can orchestrate the integration, which it seems you have but isn't working. I do understand that Inflectra Corporation is saying it's atlassian but generally the app maker (which they are for the jira app) is the one responsible to keep it working not atlassian. And in this case it seems since they can't figure it out they are just passing the blame unfortently. So the only alternative really would be to develop your own app using forge and self maintaining that, but this can be quite costly

I honestly would recommend looking at a different testing tool that has better support. Looking up their company they are a pretty small company, so finding someone either better integrated into jira like zephyr or xray or a company with larger market share maybe your best bet unfortunately

Best,

Clark

Hayden Ellison
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 5, 2024

Thank you for the response, Clark.

We will consider reaching out to them once more in hopes for better support / clarification on what the issue could be. Otherwise, we will consider changing test tools. 

 

Regards,

Hayden

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS
AUG Leaders

Atlassian Community Events