Jira Server startup stucks in "Running system startup tasks"

I had to update the DB-System. I copied the DB from a Microsoft SQL Server 2008 to a MS SQL 2014 server. Then I changed the connection string in the file bin/config.bat - test of connection was successful and started the jira-service. 

When I start the service the server stucks at step "Running system startup tasks" (for 4 hours yet) 

Version: 7.3.1

What can I do? What did I wrong?

1 answer

0 vote

Hi Martin,

Can you review this section on Switching databases to confirm you did all the required steps when migrating the data? 

It appears you need to make sure to stop Jira completely and remove the dbconfig.xml file. Then when Jira starts again it will ask you for your database configuration details.

Kind Regards,
Shannon

Hi Shannon, 

  1. I stopped the jira service via service manager on windows server
  2. I made a backup of the DB on the MS SQL 2008 2008 server
  3. I restored this DB on the MS SQL 2014 server
  4. I changed the connection string in the dbconfig.xml 
  5. I started the jira service

Well, I have already done a DB migration via XML Backup - that was successful. But I thought, that changing the DB connection string in the dbconfig.xml file should also work. So this way isn't working? 

Thank you so much! 

Hi Martin,

I would definitely recommend the steps in that article rather than updating dbconfig.xml.You can see in the steps it mentions updating dbconfig.xml if you're using the same database type, but not if you have a different database type.

Can you try deleting that file after you stop Jira and restart and let me know how it goes? 

Kind Regards,
Shannon

Ok, now I am able to connect to the database and the tables are created. But I stuck at the page, where I have to enter the db connection parameters. In the jiralog the last input is: 

active-objects-init-JiraTenantImpl{id='system'}-0 DEBUG anonymous 872x17x1 1xlxw70 10.10.10.94 /secure/SetupDatabase.jspa [c.a.activeobjects.osgi.TenantAwareActiveObjects] bundle [com.atlassian.plugins.atlassian-whitelist-api-plugin] creating ActiveObjects

It doesn't go on to the next Screen ("Set up application properties") I have been waiting for one hour now. 

Is this a proplem of the database? Or the user rights on the database? I did all steps from here: https://confluence.atlassian.com/adminjiraserver072/connecting-jira-applications-to-sql-server-2014-828787573.html 

Hi Martin,

There are still no errors showing as to why it might be hung? Is there anything in catalina.out?

I would have a look at this Jira fails to start... article at the bottom - you can see if a process is hung and if anything is locked. For example, I would see maybe if a Jira stop/start can help it or run through the suggestions in the above article.

Kind Regards,
Shannon

Hi Shannon, 

Now everything works. I created a new database and did then restored the xml backup. The main problem was that the user, who ran the sql server instance, had not the correct rights. So I guess, that just changing he connection string would also work. 

Thanks for you help! 

I have just another little Problem: At login at jira a message appears: "The Collation health check has failed in your system." 

But I set the right collation in the db. The detailed error Message is: The health check was unable to complete within the timeout of 20000ms. 

What can I do against that? 

Hi Martin,

Have a look at this article: JIRA Health Check TimeoutException. When you look at your Jira logs, there should be some more messages around the error that will be more specific.

However, it also explains how you can increase your timeout. Yours is already at 20000ms but you may be able to increase it a bit more and see if that helps.

Kind Regards,
Shannon

I think increasing the timeout is not the right way. The default value is 5000ms. So it must be done withing these 20000ms otherwise there is another problem.  

The second error that appears is: Indexing (Lucene) with the same error message. If I run a reindex manually everything is ok. But if Jira does it itself (every hour I guess) These two errors appear. 

Is the KeyAliase value influencing these operations? 

Martin,

Can you show me the errors as they appear in a screenshot? 

When you ran the indexing, did you do a background reindex or a full Jira lock and reindex?

There are a few errors listed here that you could run into along with their troubleshooting steps, but as far as I can tell the error you're experiencing is not listed here: HealthCheck: Lucene Search Indexes. Have a look, nonetheless.

Regarding the KeyAlias value, I do not believe this should affect this problem.

Kind Regards,
Shannon

I ran a background reindex, but no user did any changes meanwhile. 

In Jira -> Systems -> Support Tools: 

image.png

 

In the atlassian-jira.log file: image.png

Martin,

Thank you!

Out of curiosity, can you show me the exact collation that your database is using? 

Kind Regards,
Shannon

I am using the same collation as it is described here: 

https://confluence.atlassian.com/adminjiraserver071/connecting-jira-applications-to-sql-server-2014-808761244.html 

image.png

 

But I don't think that this has anything to do with the collation itself, because I got an timeout and another reason is that if I run the reindexing manually everything works fine. 

It is also noticeable to me that the reindexing takes much longer than before moving Jira to the new database. 

 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

523 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you