Jira Plugin Development for jira 4.4.5 - running standalone jira 4.4.5

I am getting started on developing a plugin for jira. I downloaded the SDK and am going through the tutorial.

The SDK comes configured for developing with jira 5, and I need to develop a plugin against jira 4.4.5

One of the first steps in the tutorial is running a standalone jira instance using this command:

atlas-run-standalone --product jira --version 4.4.5

This succesfully starts jira, and I can connect to it from my browser (http:/localhost:2990/jira)

The problem is that the web page looks like its missing formatting, menus, buttons etc. I think some resources (css etc) isn't there. If I run the standalone version without specifying the version parameter, I can see a clean set of jira pages through my browser.

I am using these versions:

ATLAS Version: 4.1.2

Java version: 1.6.0_29

1 answer

0 votes

What browser are you using? From memory, jira in IE (8?) doesn't work properly when jira.dev.mode is on. Think it's probably to do with the fact that resource batching is off and IE can only cope with 32 stylesheets.

It's possible to work round this but you're better off just getting a proper browser.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

23,272 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you