Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Gadget "gadget.common.error.500" issues.

Read just about everything I can find on this issue.

Tried the http(s)nonProxy settings in setenv.sh and catalina.properties (this broke my ldaps authentication. 

2019-11-08 18:51:57,968 http-nio-8081-exec-25 ERROR anonymous 1131x202x1 1cllxaz xx.xxx.xx.xxx,10.255.254.105 /login.jsp [c.a.c.manager.application.ApplicationServiceGeneric] Directory 'LDAPS' is not functional during authentication of 'username'. Skipped.

 

 

The jira server is in AWS/EC2

There is an AWS ELB (ALB) handling SSL and http->https redirect

 

server.xml

        <Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"

                   maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"

                   maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"

                   acceptCount="100" disableUploadTimeout="true" bindOnInit="false" proxyName="jira.domain.com" proxyPort="80"/>

 

        <Connector port="8081" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"

                   maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"

                   maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"

                   acceptCount="100" disableUploadTimeout="true" bindOnInit="false" proxyName="jira.domain.com" proxyPort="443" scheme="https" secure="true"/>

 

 

 

1 answer

0 votes

Hello John,

Welcome to Atlassian Community. Sorry to hear you are facing this problem.

Can you please let us know what are the actions you took to reproduce this error? Also, can you please let us know what is the dashboard gadget reproducing this issue?

Checking for similar errors, I identified a problem related to the activity stream gadget:

Jira activity stream gadget throws gadget.common.error.500

Can you please try the diagnose steps and check if that's what is causing your issue?

Let me know if you have any questions.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you