[Jira/Confluence] Application Link or OAuth Problem (Gadgets not shown for every user)

Hello!



System setting
We have a Confluence 4.3.7 and a Jira 5.2.5 server up and running:
https://<my-jira-server>:8080/jira/
https://<my-jira-server>:8090/confluence/

They are connected via an Application Link (configured in Jira). We activated the Trusted Application and OAuth feature. Outgoing/Incoming we added localhost and additionally the IP of the server where both Jira und Confluence are running.

To use Jira Gadgets within Confluence we configured a Gadget feed:
http://<jira-server-IP>:8888/jira/rest/gadgets/1.0/g/feed

And yes there is a proxy somewhere.



Problem description
Initially we just wanted to print a dashboard to have a report for our boss. (And he wants and needs it!) Unfortunatelly this feature is not implemented in Jira and the printing from browser is bugged.

The solution we found is to create our own report in Confluence with the help of Jira Gadgets. But we are neither able to print this report with the browser print function nor with the Confluence built-in possibility (charts are simply broken). So we installed the Firefox Plugin PrintPDF which now allows us the print the report.

Nice and shiny report! Wouldn't there be the tiny flaw that only my colleague and I are able to see the gadgets (seeing the charts). All my other team members simply see an empty window.

That's what users see instead of charts

I analysed this error with FireBug and it seems like the client isn't receiving any answer.

We also found this log entry:

733 com.atlassian.mywork.client.reliability.DefaultUnreliableWorker:thread-1 WARN 21127 786x33x1 1y117f6 10.3.66.36 /secure/QuickCreateIssue.jspa 

[apache.commons.httpclient.HttpMethodDirector] Unable to respond to any of these challenges: {oauth=OAuth realm="https%3A%2F%2F&lt;my-server&gt;%3A8090%2Fconfluence"}



What we tried so far
Funny things seem to happen here...

  • My team members (where the report is NOT working) logged on to Confluence on my PC and magically the report worked. They are able to see the "permission granting screen", where they have to click 2-3 times to allow Confluence to use their Jira credentials to receive data. But after moving back to their own workstation, it doesn't work anymore.
  • I also looked up the granted OAuth Tokens. My team mebers didn't have any (even they clicked on granting them and the report worked). Also when I deleted all my OAuth Tokens I was still able to see the report in perfect shape.
  • When I log on to Confluence on the PC of my other team members (Where the report is not working) the report doesnt work - charts are broken. I don't even see the "permission granting screen".
  • We tried to enable Basic Access in the Application Link.


We worked for around a week to solve this problem now, but don't seem to be able to find any suitable solution. This becomes really annoying as actually the report generation in Confluence is just a work around for the not properly working (or not even built in) "Print Dashboard" feature.

Thanks!

4 answers

1 accepted

What was the solution? Can you share? I have same scenario here.

We solved this question with an Atlassian Support Call.

We solved this question with an Atlassian Support Call.

We solved this question with an Atlassian Support Call.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

164 views 1 17
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you