Jira Bamboo Plugin will not "Enable" for Bamboo v4.3.3 or v5.0.1

Jira Bamboo Plugin stopped working after updating Jira to v6.0.6. Was at Bamboo v4.3.3. Updated Bamboo to v5.0.1 and still get the same problem. Log file shows the following (note: the how-to page listed "http://confluence.atlassian.com/x/1xy6D" does not exist):

=== atlassian-bamboo.log Pre-Bamboo v5.0.1 install ========

2013-08-16 00:26:16,653 ERROR [WrapperSimpleAppMain] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.jira.plugin.ext.bamboo' : Unresolved constraint in bundle com.atlassian.jira.plugins.jira-bamboo-plugin [55]: Unable to resolve 55.0: missing requirement [55.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.jira)(version>=5.0.0)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D

=== atlassian-bamboo.log Post-Bamboo v5.0.1 install ========

2013-08-20 10:00:02,296 ERROR [WrapperSimpleAppMain] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.jira.plugin.ext.bamboo' : Unresolved constraint in bundle com.atlassian.jira.plugins.jira-bamboo-plugin [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=com.atlassian.jira)(version>=6.0.0)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D
2013-08-20
10:00:02,298 WARN [WrapperSimpleAppMain] [OsgiPlugin] Unable to enable plugin 'com.atlassian.jira.plugin.ext.bamboo'
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.jira.plugin.ext.bamboo
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:445)
at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:725)
at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:178)
at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:182)
at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:147)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:190)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:93)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:40)
at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:733)
at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:233)
at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1222)
at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:676)
at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:455)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:90)
at org.eclipse.jetty.server.Server.doStart(Server.java:261)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
at com.atlassian.bamboo.server.Server.main(Server.java:74)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:240)
at java.lang.Thread.run(Unknown Source)
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.jira.plugins.jira-bamboo-plugin [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=com.atlassian.jira)(version>=6.0.0))
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:417)
... 26 more

2 answers

0 votes
Yilin Mo Atlassian Team Aug 20, 2013

Maybe you should try the lastest version of Bamboo plugin

https://marketplace.atlassian.com/plugins/com.atlassian.jira.plugin.ext.bamboo

As it had been recently compatible with JIRA 6.

This is with the latest version of the Jira Bamboo plugin installed:

Version: 6.1.7
Developer:Atlassian Software Systems Pty Ltd
Add-on key: com.atlassian.jira.plugin.ext.bamboo

Note also, that the listing under "User-installed Add-ons" is grey out as well (probobly indicating that it is disabled).

As mentioned in my reply to the last comment, I have used the lastest version of Bamboo plugin and still have the same error. The issue is still NOT resolved.

This is with the latest version of the Jira Bamboo plugin installed:

Version: 6.1.7
Developer:Atlassian Software Systems Pty Ltd
Add-on key: com.atlassian.jira.plugin.ext.bamboo
Note also, that the listing under "User-installed Add-ons" is grey out as well (probobly indicating that it is disabled).

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,866 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot