Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Backup Fail Edited

Hello,

Trying to migrate on new Jira instance.

  • v6.4.12#64027-sha1:e3691cc)
  • Oracle DB

When I perfom backup from JIRA (from Backup System)

I always get the error:

An exception occurred backing up: org.ofbiz.core.util.GeneralRuntimeException: Error creating GenericValue (SQL Exception while getting value: (Invalid column type: getBLOB not implemented for class oracle.jdbc.driver.T4CLongRawAccessor))

 Found the same error here: https://confluence.atlassian.com/jirakb/invalid-column-type-getblob-not-implemented-for-class-oracle-jdbc-driver-t4clongrawaccessor-during-backup-process-854131615.html

Made this:

desc propertydata
Name          Null     Type       
------------- -------- ---------- 
ID            NOT NULL NUMBER(18) 
PROPERTYVALUE          BLOB       

But this doesn't help, still get the error. 

Cant find another way to migrate.

Any ideas? 

 

Caused by: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while getting value:  (Invalid column type: getBLOB not implemented for class oracle.jdbc.driver.T4CLongRawAccessor)
	at org.ofbiz.core.entity.jdbc.SqlJdbcUtil.getValue(SqlJdbcUtil.java:728)
	at org.ofbiz.core.entity.EntityListIterator.currentGenericValue(EntityListIterator.java:169)
	at org.ofbiz.core.entity.EntityListIterator.next(EntityListIterator.java:246)
	... 199 more
Caused by: java.sql.SQLException: Invalid column type: getBLOB not implemented for class oracle.jdbc.driver.T4CLongRawAccessor
	at oracle.jdbc.driver.Accessor.getBLOB(Accessor.java:1270)
	at oracle.jdbc.driver.OracleResultSetImpl.getBLOB(OracleResultSetImpl.java:1623)
	at oracle.jdbc.driver.OracleResultSetImpl.getBlob(OracleResultSetImpl.java:585)
	at org.apache.commons.dbcp.DelegatingResultSet.getBlob(DelegatingResultSet.java:550)
	at org.apache.commons.dbcp.DelegatingResultSet.getBlob(DelegatingResultSet.java:550)
	at org.ofbiz.core.entity.jdbc.SqlJdbcUtil.getValue(SqlJdbcUtil.java:647)
	... 201 more

 

2 answers

2 accepted

1 vote
Answer accepted

Hi Artem,

If you are still running into this issue please run the database integrity checker for JIRA.  If it finds any issues let it fix the problems per step 4 of the Using the database integrity checker knowledge base article.

In addition, it appears you may be running into the bug documented in JRASERVER-47267.  Please review that bug ticket and follow the work around if you agree that applies to your situation.

Cheers,

Branden

You're right. It was JRASERVER-47267. 

And I was resolve the situation in few hours with atlassian support team.

Thank you!

 

0 votes
Answer accepted

jiraerror.JPG

I am getting this erroe while taking the backup. can you help me in this. i need to switch my jira server o jira cloud.

I want to move it to jira cloud with all my attachments and backup. Please help me in doing that.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you